Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал icon

Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал



НазваниеЗадания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал
страница3/3
Дата конвертации08.09.2012
Размер362.44 Kb.
ТипДокументы
1   2   3

Определите результат при m=2, n=4

БЕЙСИК

ПАСКАЛЬ

if m>n then

if n >0 then

print m

else

print n

endif

else

print n+m

endif

if m>n then

if n >0

then writeln(m)

else writeln(n)

else writeln(n+m);



^ Определите значение целочисленной переменной х после выполнения следующего фрагмента программы:



1)

1

2)

5

3)

10

4)

15



^ Значение переменной R, вычисленное по блок-схеме равно:



Функция F вычисляется следующей программой


БЕЙСИК

ПАСКАЛЬ

input X

if X=1 then

F=0

еlse if INT(X/2)=1 then

F=3*X+1 +1

else F=(X div 2)*2

end if


Program Functiay;

var

x,F : integer;

begin

readln(X);

if X=1 then F:=0

else

if Odd(X) then F:=3*X+1 +1

else F:=(X div 2)*2

end.


^ Чему равно значение функции F при х=26 ?


В результате выполнения фрагмента программы значение переменной Y будет равно:

БЕЙСИК

ПАСКАЛЬ

y=0

x=1

while (x>4)

y=y+x^2

x=x+1

wend print y

y:=0;

x:=1;

while x>4 do begin

y:=y+x*x ;

x:=x+1;

end;

writeln(y);


^ После выполнения программы последнее значение, которое будет выведено на экране, равно:

БЕЙСИК

ПАСКАЛЬ



for i=14 to 10 step-1

print i-1

next i


var

i:integer;

begin

for i:=14 downto 10 do

writeln((i-1))

end.


^ Почему цикл будет выполняться бесконечно


БЕЙСИК

ПАCКАЛЬ


d=1: s=0

do

s=s+d

loop while d<100




d:=1; s:=0;

repeat

s:=s+d;

until d>100;





  1. Потому, что d в цикле не изменяется;

  2. Потому, что условие не выполняется;

  3. Потому, что в цикле d=1.


После выполнения программы z будет равно:


БЕЙСИК

ПАСКАЛЬ

z=2

for i=10 to 14

z=z+3

next i

print z

Var

i,z:integer;

begin

z:=2;

for i:=10 to 14 do

z:=z+3;

write(z:2);

end.




  1. 7 2) 17 3) 10 4) 11 5) 12



^ Сколько раз выполнится тело цикла в программе:

БЕЙСИК

ПАСКАЛЬ

i=20

do while I<= 20

i=i+1

print i

loop

end


var

i:integer;

begin

i:=20;

while I<= 20 do

i:=i+1;

writeln(i);

end.





  1. бесконечно

  2. 1 раз

  3. ни разу

  4. 5 раз

  5. 11 раз


До какого числа должно изменяться значение i во фрагменте алгоритма, чтобы а стало равно 15:

а:=1

нц для i от 2 до ...

а:= а*1

a:= a+i

кц

  1. 15 2) 8 3) 9 4) 5 5)10


^ Чему будет равно значение b в результате выполнения программы:

БЕЙСИК

ПАСКАЛЬ

b=1 : a=1

for i=1 to 3

x=a*i

if x>=0 then b=b+x

a= - a

next i

print b

end


var a,b,x:integer;

begin

b:=1; a:=1;

for i:=1 to 3 do begin

x:=a*i;

if x>=0 then b:=b+x;

a:=-a;

end;

writeln(b)

end.

1) 2 2) 8 3) 1 4) 7 5) 5


^ При выполнении программы при N=3 на экран будет выведено число:

БЕЙСИК

ПАСКАЛЬ

INPUT N

S=0

FOR K=1 to N

S=S+N^2

Print S

NEXT K

END

Var N,S,K:integer;

Begin

readln( N);

S:=0;

FOR K:=1 to N do

S=S+N*N;

Writeln( S); end.

  1. 14; 2) 9; 3) 6; 4) 10; 5) 27.



^ Вычисляемое в программе значение переменной т для n=925 равно:

БЕЙСИК

ПАСКАЛЬ




Input n

m = n mod 10 : k =m

do while n>0

a =n mod 10

n = n div10

if a>m then m=а

if а < k then k=а

loop

m=m div k

Read(n);

m = n mod 10; k: =m:

While n>0 do

begin

a: =n mod 10; n: = n div10;

if a>m then m: = а;

if а < k then k: =а;

end;

m:=m div k




1) 10

2) 8

3) 6

4) 4

^ Тело цикла во фрагменте алгоритма выполнится

m:=36; n:=56

нц пока m < > n

если m > n

то m:=m-n

иначе n:=n-m

все

кц

1) 0 раз 2) 4 раза 3) 6 раз 4) 8 раз


Для массива Х[1..n] алгоритм

S:=0;

Нц для k от 1 до N

Если (X[k]<0)

То S:=S+1

Все

Кц

определяет:

  1. Минимальный элемент массива

  2. Сумму отрицательных элементов

  3. Количество отрицательных элементов

  4. Индекс последнего, отрицательного элемента массива

  5. Индекс первого отрицательного элемента массива



Если элементы одномерного массива R(4) равны соответственно 5, 5, 1, -2, то значение выражения R(1-R(4)) + R(-3+R(1)) равно

1) 0 2)1 3) –2 4) 6 5) 4


^ Вместо точек во фрагмент программы

M:=0;

нц для k:=1 до N

если …….

то M:=k

всё

кц

определяющей номер последнего элемента массива Р(N), не равного Х, нужно вписать логическое выражение

  1. Р(k)=X 2) Р(k)X 4) i<=N 5) Р(k)< >M



^ Задан двумерный массив А(N,N):

11 12 13

0 4 3

-1 0 14

В результате работы фрагмента алгоритма

нц для i от 1 до n

нц для j от 1 до n

c:=A(i,j); A(i,j):=A(j, i); A(j, i):=C;

кц

кц

значения переменных будут соответственно равны:

  1. A(3,1)=13, A(2,3)=4

  2. A(3,1)=14, A(2,3)=0

  3. A(3,1)=12, A(2,3)=11

  4. A(3,1)=-1, A(2,3)=13

  5. A(3,1)=13, A(2,3)=0




Значения двумерного массива задаются с помощью вложенных циклов. Определите, какое значение приобретет элемент массива A(3,2).

БЕЙСИК

АЛГОРИТМИЧЕСКИЙ ЯЗЫК

For n=1 To 5

For k=1 To 5

If n>k Then A(n,k)=(n+k)

Else A(n, k)=(n*k)

Next k

Next n

нц для n от 1 до 5

нц для k от 1 до 5

если n>k

то А[n, k]=(n+k)

иначе A(n, k)=(n*k)

кц

кц




1) 2 2) 3 3) 5 4) 6

^ Вычисляемое в программе

БЕЙСИК

ПАСКАЛЬ

DEFINT I, J, K, S
DIM A(3, 3) AS INTEGER
FOR I=1 TO 3
FOR J=1 TO 3
A(I, J)= I MOD J
NEXT J

NEXT I
S=0
FOR I=2 TO 3
FOR J=1 TO 4-I
IF A(J, I+J-1)=1 THEN S=S+1
NEXT J

NEXT I
PRINT S

VAR I, J, S: INTEGER
A: ARRAY [1..3, 1..3] OF
INTEGER;
BEGIN
FOR I:=1 TO 3 DO
FOR J:=1 TO 3 DO
A[I, J]:=I MOD J;
S:=0;
FOR I:=2 TO 3 DO
FOR J:=1 TO 4 - I DO
IF A[J, I+J-1]=1 THEN
S:=S+1;
WRITE (S)
END.

значение переменной S равно_____________

Вычисляемое значение переменной т равно

БЕЙСИК

ПАСКАЛЬ

FOR I=1 ТО 4

IF MOD(I, 2)<>0 THEN А(I)=6*I-2 ELSE A(I)=DIV(I, 2)

NEXT I

FOR I=1 ТО 3

FOR J=1TO 4-I

IF A(J)
NEXT J

NEXT I

M=A(1)

for i: = 1 to 4 do

if i mod 2 <> 0 then [i]:=6*i-2

else a[i]:=i div 2;

for i:=1 to 3 do

for j: = 1 to 4 - i do

if a[j]
begin r: =a[j]; a[j]: =a[j+l]; a[j + 1]: = r end;

m:=a[l];


1) 8


2)1


3)16



4)12


^ После выполнения фрагмента программы формируется матрица А(4,4) вида:


БЕЙСИК

ПАСКАЛЬ

FOR I=1 ТО 4

FOR J=1TO4

IF I=4-J+1 THEN A(I, J)=I ELSE A(I, J )= 0 NEXT J

NEXT I

for i: =l to 4 do

for j: = 1 to 4 do

if i = 4-j +1 then a[i, j]: = i else a[i, j]: =0;




1)

0

0

0

1

2)

0

0

0

1

3)

1

1

1

1

4)

1

0

0

0




0

0

0

2




0

0

2

0




0

2

2

2




0

2

0

0




0

0

0

3




0

3

0

0




0

0

3

3




0

0

3

0




0

0

0

4




4

0

0

0




0

0

0

4




0

0

0

4
1   2   3



Похожие:

Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconЗадания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал
Модем передаёт информацию со скорость 56600 бод. Какой объём информации он передаст за 1 минуту?
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconКафедра геоинформатики
Обзор отечественных и зарубежных забойных телесистем. Акустический канал связи. Телесистемы с гидравлическим каналом связи. Электромагнитный...
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconПамятка для выпускников как вести себя во время сдачи экзаменов в форме егэ
Всегда есть задания, которые ты в силах решить. Задания разрабатываются в соответствии с программой общеобразовательной школы и отвечают...
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconДемонстрационный вариант по математике для учащихся 6 класса
В первой части 20 заданий, во второй – 3 задания, в третьей – 2 задания. Часть 1 это задания с выбором одного верного ответа из четырех....
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconДемонстрационный вариант по истории для учащихся 6 класса 2011-2012 учебный год Инструкция по выполнению работы
В – 3 задания, в части с – 3 задания. Часть а это задания с выбором одного верного ответа из четырех. Задания части в – задания на...
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconДилатация компенсаторная реакция сердца на нагрузку объемом гипертрофия- компенсаторная реакция сердца на нагрузку давлением
Поражения митрального и «аортальных» клапанов имеют место чаще чем трехстворчатого и «легочных» клапанов
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconКак правильно выбрать корпоративную информационную систему
Недосекин А. О., Корольков М. Д., Сегеда А. В. Как правильно выбрать корпоративную информационную систему
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconПодготовка к экзаменационной работе в форме егэ 9 класс Задания 1- 4
Какое средство художественной выразительности использует М. Горький в 16 предложении текста?
Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconДокументы
1. /задания на нормализацию/АС09И1/Авдеев.txt
2. /задания...

Задания, выраженные в закрытой форме Сложность: 1 Самую высокую информационную нагрузку несет канал iconВнеклассное мероприятие для 2-х классов Подготовила: Литвинова Ольга Дмитриевна воспитатель гпд моу «сош г. Бирюча»
Ведущий: Здравствуйте, дорогие ребята! Нам очень приятно видеть всех Вас сегодня в нашем спортзале! Мы начинаем самую весёлую из...
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов