Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я icon

Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я



НазваниеНачала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я
Дата конвертации07.10.2012
Размер446 b.
ТипМетодическая разработка


Начала информатики. Алгоритмический язык программирования ЛОГО. Методическая разработка - презентация учителя информатики Солодовниковой Т. Я.


Цели: 1. Познакомить с понятиями алгоритм и программа. 2. Познакомить с командами алгоритмического языка ЛОГО. 3. Пробудить желание экспериментировать. Задачи: 1. Научить общению с компьютером в режиме диалога на языке ЛОГО. 2. Научить основам программирования на алгоритмическом языке ЛОГО. 3. Развивать алгоритмическое мышление.



Темы уроков.

  • Урок 1. Введение.

  • Урок 2. Углы и их измерение.

  • Урок 3. «Черепашья графика».

  • Урок 4. Ритм и повторение.

  • Урок 5. Построение правильных многоугольников.

  • Урок 6. Построение окружности и дуги.

  • Урок 7. Процедуры.

  • Урок 8. Процедуры с параметрами.

  • Урок 9. Рекурсивные процедуры.

  • Урок 10. Координаты.



Думаем и исследуем на ЛОГО.



Урок 1. Введение.



Немного истории…

  • Язык программирования ЛОГО был разработан в конце

  • 60-х годов американским исследователем в области

  • искусственного интеллекта С. Пейпертом.

  • Название языка происходит от греческого слова «LOGOS» - «слово», «мысль», «смысл», «идея».

  • В языке используется

  • специальный исполнитель

  • команд

  • «черепашка».

  • Она точно выполняет

  • все команды учащегося.



Алгоритм и программа - основные понятия информатики.

  • Алгоритм – конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату.

  • Алгоритм можно записать в виде нумерованного списка

  • (словесная форма) или изобразить с помощью

  • блок-схемы.

  • Программа – это алгоритм, записанный на языке

  • программирования.

  • Уметь программировать – значит

  • строить алгоритм, т. е.

  • последовательность команд,

  • приводящих к нужному результату, и

  • правильно записывать команды на

  • языке программирования.



Базовые команды черепашки.

  • Черепашку можно научить многим командам, но она имеет и некоторый начальный уровень образованности и выполняет следующие базовые команды

  • вперед, назад, направо, налево.



Запомни:

  • Для выполнения команд вперед и назад необходимо задать черепашке количество шагов (число).

  • Для выполнения команд направо и налево необходимо указать черепашке, на сколько градусов повернуться (число), считая от её текущего положения.

  • Между командой и числом ставится пробел.



Выполним:

  • вперед 100



Выполним:

  • назад 100



Выполним:

  • направо 90



Выполним:

  • налево 90



Выполним в программе ЛОГОМИРЫ:







Запомни:



Черепашка, повернись!

  • Черепашка двигаясь по экрану,

  • должна выдержать заданное направление.

  • Поэтому перед движением обязательно

  • задаётся направление движения.



Направо



Налево



Измерить можно - длину отрезка на листе бумаги, - расстояние между городами, - время, - скорость движения поезда, - силу электрического тока, - влажность воздуха, - громкость звука, - температуру окружающей среды, - освещённость помещения и т. д.

  • Сегодня мы научимся измерять угловые

  • величины.

  • Повернём стрелку направо

  • и отметим её новое положение.

  • Между исходной и повёрнутой стрелками

  • образовался угол.

  • Этот угол обозначен цифрой 1.



Чтобы точно сравнивать углы и определять их величину, надо научиться их измерять.

  • Посмотрим на часы:

  • По циферблату бежит секундная стрелка.

  • Условимся считать начальным положением

  • стрелки самую верхнюю точку циферблата,

  • отмеченную числом 12.

  • Стрелка побежала от начального положения и угол между её начальным

  • положением и текущим положением стал увеличиваться.

  • Угол растёт до тех пор, пока стрелка не пробежит полный круг.

  • Стрелка пробежала полный круг и оказалась

  • опять в точке циферблата, отмеченной числом 12.

  • Такой угол, который соответствует полному обороту стрелки, считают

  • равным 360 градусам.



Измерение углов.

  • Угол, который описывается стрелкой, пробежавшей

  • полкруга, равен 180 градусам.

  • Угол, который описывается стрелкой, пробежавшей

  • четверть круга, равен 90 градусам.

  • Угол, равный 1 градусу, это очень маленький угол,

  • но можно измерять и меньшие углы. Однако мы не

  • будем использовать такие маленькие углы.

  • Углы можно складывать.

  • Например: один угол равен 90 градусов, а второй угол

  • равен 45 градусам.

  • Сумма этих углов будет равна 135 градусам.



Углы бывают:



Углы бывают:



Углы бывают:



Урок 3. «Черепашья» графика.



Язык ЛОГО имеет большие графические возможности.

  • Язык ЛОГО имеет большие графические возможности.

  • Перемещаясь по экрану компьютера черепашка может оставлять след, подобно живой черепахе, которая волочит свой хвост по песку.

  • Эту её способность мы будем использовать, чтобы чертить фигуры на экране.



Запомни:

  • Черепашка может двигаться по экрану оставляя след, а может и не оставлять след.

  • Чтобы черепашка оставляла след нужно дать команду

  • Перо Опусти – ПО

  • Чтобы черепашка не оставляла след нужно дать команду

  • Перо Подними – ПП



Задание 1.

  • Научим черепаху рисовать прямоугольник.

  • Одна сторона этого прямоугольника будет 100 шагов,

  • другая - 160 шагов. Все углы у прямоугольника - прямые, значит

  • повороты черепашки при переходе со стороны на сторону

  • будут 90 градусов.



Составим алгоритм в виде нумерованного списка (словесная форма):

  • Начало.

  • Вперёд на величину ширины прямоугольника.

  • Поворот на 900 вправо.

  • Вперёд на величину длины прямоугольника.

  • Поворот на 900 вправо.

  • Вперёд на величину ширины прямоугольника.

  • Поворот на 900 вправо.

  • Вперёд на величину длины прямоугольника.

  • Поворот на 900 вправо.

  • Конец.



Черепаха, шагом марш!

  • Напишем программу на языке ЛОГО:

  • по

  • вперед 100

  • направо 90

  • вперед 160

  • направо 90

  • вперед 100

  • направо 90

  • вперед 160

  • направо 90

  • Выполним в программе

  • ЛОГОМИРЫ:





Программировать – значит и редактировать.

  • При построении прямоугольника и квадрата черепашка двигалась,

  • поворачиваясь только

  • Направо.

  • Теперь попросим её нарисовать такие же фигуры,

  • но поворачиваясь только

  • Налево.

  • Для этого отредактируем наши программы,

  • т. е. заменим команду Направо на команду Налево.





Задание 4.

  • Построим равносторонний треугольник.

  • Длина стороны 100 шагов.

  • Все углы в равностороннем

  • треугольнике равны 600 .

  • Составим алгоритм в виде блок-схемы.



Напишем программу на языке ЛОГО:

  • по

  • вперед 100

  • направо 120

  • вперед 100

  • направо 120

  • вперед 100

  • направо 120

  • Выполним в программе

  • ЛОГОМИРЫ:



Задание 5.

  • Построим уголок. Длина линии 50 шагов.

  • по

  • направо 45

  • вперед 50

  • направо 90

  • вперед 50

  • налево 90

  • Выполним в программе ЛОГОМИРЫ:



Задание 6.

  • Построим фигуру. Длина линии 50 шагов. Угол поворота 900 .

  • по

  • вперед 50

  • направо 90

  • вперед 50

  • направо 90

  • вперед 50

  • налево 90

  • вперед 50

  • налево 90

  • Выполним в программе ЛОГОМИРЫ



Урок 4. Ритм и повторение.



Окружающий нас мир полон ритмов.

  • Есть свой ритм в звуке шагов,

  • в стуке и грохоте машин,

  • в пении птиц.

  • Ритмично сменяют друг друга дни и ночи,

  • дни недели,

  • времена года.

  • Этот ритм задаётся движением Земли.

  • Ритм лежит в основе музыки.

  • Ритм в музыке задаётся тактом.

  • Ритм неотступно сопровождает каждого их нас с первой

  • до последней минуты жизни – это ритм бьющегося

  • сердца.



  • Ритм – это многократное повторение

  • чего – либо.

  • В программировании повторение называется ЦИКЛОМ.

  • В программировании повторяться могут только команды.

  • В ЛОГО – повторение некоторое количество раз одной или нескольких команд обеспечивает команда

  • Повтори



Запомни:

  • Заключённая в квадратные скобки последовательность команд называется телом цикла.

  • При выполнении команды цикла, тело повторяется столько раз, сколько

  • указывает число, стоящее после слова Повтори.

  • Например:

  • Повтори 4[Вперед 100 Направо 90]



Используем команду Повтори для построения фигур. Пример 1.

  • Для построения квадрата команда черепашке будет

  • выглядеть так:

  • повтори 4 [вперед 100 направо 90]



Пример 2.



Пример 3.

  • Для построения пяти уголков команда черепашке будет

  • выглядеть так:

  • направо 45

  • повтори 5 [вперед 50 направо 90 вперед 50 налево 90]



Пример 4.

  • Начертим вертикальную пунктирную линию.

  • Линия содержит 10 пунктиров,

  • длина каждого пунктира 10,

  • расстояние между пунктирами 5.

  • повтори 10 [по вперед 10 пп вперед 5 ]



Пример 5.

  • Начертим горизонтальную пунктирную линию.

  • Линия содержит 10 пунктиров,

  • длина каждого пунктира 10, расстояние между пунктирами 5.

  • направо 90

  • повтори 10 [по вперед 10 пп вперед 5 ]



Пример 6.

  • Какую фигуру начертит черепаха после

  • выполнения команд:

  • по

  • повтори 2 [вперед 50 направо 90

  • вперед 50 направо 90 вперед 50

  • налево 90 вперед 50 налево 90]



Черепаха начертит:



Пример 7.

  • Какую фигуру начертит черепаха после

  • выполнения команд:

  • по

  • повтори 5 [вперед 50 направо 90

  • вперед 50 налево 90]



Черепаха начертит:



Урок 5.

  • Построение правильных многоугольников.



  • Правильными называются многоугольники,

  • у которых все стороны и углы равны.

  • Чтобы построить любой правильный многоугольник,

  • воспользуемся командой

  • повтори.



Получим значение угла поворота.

  • Для этого

  • 3600 (число градусов в полном круге) разделим на

  • N (число углов многоугольника)

  • 360/N



Получим значение угла поворота:

  • 360/3=120 – для треугольника

  • 360/4=90 – для прямоугольника

  • 360/5=72 – для пятиугольника

  • 360/6=60 – для шестиугольника

  • 360/8=45 – для восьмиугольника



Построим фигуры.

  • 1. Правильный треугольник:

  • повтори 3[ вперед 100 направо 120]

  • 2. Правильный прямоугольник:

  • повтори 4 [вперед 100 направо 90]



Построим фигуры.

  • 3. Правильный пятиугольник:

  • повтори 5[вперед 100 направо 72]

  • 4. Правильный шестиугольник:

  • повтори 6[вперед 100 направо 60]

  • 5. Правильный восьмиугольник:

  • повтори 8[вперед 100 направо 45]

  • Выполним в программе ЛОГОМИРЫ:



Урок 6.

  • Построение окружности.



  • Любую окружность можно считать

  • правильным многоугольником с очень малой

  • стороной и соответственно очень малым

  • углом поворота.

  • Для построения окружности будем использовать команду повтори.



Формула окружности.

  • Для значения угла поворота, равного N, получим

  • формулу окружности:

  • Построим окружность в виде 360-угольника.

  • Найдём угол поворота: 3600/360 = 10

  • Длину стороны возьмём за 1шаг.

  • Используем команду:

  • повтори 360[вперед 1 направо 1]

  • Выполним в программе ЛОГОМИРЫ:



Пользуясь формулой окружности заполним таблицы:

  • Уменьшение Увеличение

  • окружности: окружности:



Построим окружности разного размера пользуясь данными таблиц:

  • Повтори 180 [вперед 1 направо 2]

  • Повтори 400 [ вперед 1 направо 0.9]

  • Повтори 36 [ вперед 1 направо 10]

  • Повтори 514 [ вперед 1 направо 0.7]

  • Повтори 120 [ вперед 1 направо 3]



Построение дуги.

  • Дуга – это часть окружности.



  • Например:

  • 1. Эта дуга – половина окружности, поэтому количество

  • повторений надо уменьшить в два раза:

  • повтори 180 [вперед 1 направо 1]

  • 2. Эта дуга – четверть окружности, поэтому количество

  • повторений надо уменьшить в четыре раза:

  • повтори 90 [вперед 1 направо 1]



Задание.

  • Построить дугу, которая составляет восьмую часть

  • окружности.

  • повтори 45 [вперед 1 направо 1]

  • Выполним в программе ЛОГОМИРЫ.



Урок 7.

  • Процедуры.



  • Процедура – это программа,

  • т. е. последовательность

  • известных черепашке (базовых)

  • команд, имеющая имя.

  • По этому имени процедуру можно

  • вызывать,

  • т. е. выполнять все входящие в неё

  • команды.



Запомни:

  • Процедура состоит из трёх частей:

  • 1. Заголовок процедуры.

  • 2. Тело процедуры (описание).

  • 3. Окончание процедуры.



Запомни:



Вызов процедуры. Имя процедуры, использованное в качестве команды, называется вызовом процедуры.



Задание 1.

  • Составим процедуру квадрат:

  • это квадрат

  • по

  • повтори 4 [вперед 100 направо 90]

  • конец

  • Вызов процедуры - квадрат



Задание 2.

  • С помощью процедуры квадрат изобразить квадрат,

  • повёрнутый на 45 градусов:

  • направо 45

  • квадрат



Задание 3.

  • Используя процедуру квадрат заставить квадрат

  • покружиться на месте:

  • повтори 18 [квадрат направо 20]



Задание 4.

  • Составить процедуру дуга и используя эту процедуру

  • нарисовать лепесток .

  • это дуга

  • по

  • повтори 45 [вперед 1 направо 2]

  • конец

  • дуга направо 90 дуга



Задание 5.

  • Имея описание процедуры дуга напишите программу,

  • которая рисует цветочек, состоящий из четырёх лепестков:



Программа на ЛОГО:

  • это дуга

  • по

  • повтори 45[ вперед 1 направо 2]

  • конец

  • повтори 4 [дуга направо 90 дуга]



Задание 6.

  • Имея описание процедуры дуга, нарисовать море:



Программа на ЛОГО:

  • это дуга

  • по

  • повтори 180 [вперед 1 направо 1]

  • конец

  • повтори 5 [дуга налево 180]



Урок 8.

  • Процедуры и параметры.



  • Составим программу - процедуру, которая будет рисовать квадрат, но вместо

  • конкретного количества шагов, определяющего размер квадрата,

  • поставим параметр - переменную, значение которой можно изменять.



Процедура с параметром:

  • это квадрат :сторона

  • повтори 4 [вперед :сторона направо 90]

  • конец

  • Параметр :сторона указан в заголовке процедуры

  • вслед за её именем.

  • Этот же параметр встречается (обязательно) и в теле

  • процедуры, в том месте, где предусмотрено

  • использование переменной величины.



Запомни:

  • Параметр - переменную можно представить себе как ящик, на котором написано имя, а внутри находится значение.

  • Это значение можно изменять.

  • Перед именем переменной ставится двоеточие,

  • пробел между двоеточием и именем переменной

  • не допускается.



Переменные в процедурах называются параметрами. - Значения параметров внутри процедуры не меняются. - Параметры, указываемые в описании процедуры ( в её заголовке и в теле), называют формальными параметрами её описания. - Формальный параметр всегда представляет собой имя некоторой величины.



Запомни:

  • В момент вызова процедуры с параметрами

  • надо указать значение этого параметра:

  • квадрат 100

  • Это значит, что значение переменной

  • для команды вперед следует взять из

  • переменной сторона,

  • которая стоит в заголовке процедуры.



Значение величины, указываемое при вызове процедуры называется фактическим параметром или параметром вызова процедуры.

  • Фактический параметр всегда является значением,

  • заменяющим собой формальный параметр в описании

  • процедуры;

  • с этим значением параметра и выполняется вызванная

  • процедура.



Процедура с несколькими параметрами.

  • Процедура с несколькими параметрами.

  • Пример 1.

  • Составим описание процедуры, рисующей прямоугольник,

  • длина и высота которого произвольны:

  • это прямоугольник :высота :длина

  • повтори 2 [вперед :высота направо 90

  • вперед :длина направо 90]

  • конец

  • Вызов процедуры: прямоугольник 50 100

  • прямоугольник



Пример 2.

  • Пример 2.

  • Составим процедуру, которая будет рисовать любой

  • правильный многоугольник, но вместо конкретного

  • количества повторений, количества шагов и угла поворота

  • поставим переменные, значение которых можно изменять:

  • это многоугольник :число :сторона :угол

  • повтори :число [вперед :сторона направо :угол]

  • конец

  • Вызов процедуры: многоугольник 6 100 60

  • шестиугольник



Урок 9.

  • Рекурсивные процедуры



Мы уже знаем, как заставить черепаху начертить круговую орбиту:

  • Мы уже знаем, как заставить черепаху начертить круговую орбиту:

  • это орбита

  • повтори 360 [ вперед 1 направо 1]

  • конец

  • Но как заставить её кружить по этой орбите подобно спутнику?

  • Для этого после того, как черепаха начертит окружность, она снова

  • должна выполнить процедуру орбита:

  • это орбита

  • повтори 360 [вперед 1 направо 1]

  • орбита

  • конец



Запомни:



Рекурсивная процедура выполняется бесконечно…

  • Прервать программу можно

  • одновременным нажатием клавиш и



Бесконечное движение черепашки по треугольной орбите:

  • это треугольник

  • повтори 3 [вперед 100 направо 120]

  • треугольник

  • конец



Бесконечное движение черепашки по квадратной орбите:

  • это квадрат

  • повтори 4 [вперед 100 направо 90]

  • квадрат

  • конец



Урок 10.

  • Координаты.



Запомни:

  • Запомни:

  • Два числа, определяющие положение точки на плоскости,

  • называются координатами.

  • Плоскость с отмеченной на ней точкой начала отсчёта и

  • проходящими через эту точку двумя линиями, называется

  • системой координат.

  • Точку начала отсчёта называют началом координат.

  • Направленные линии – осями координат.



Запомни:

  • Для того, чтобы точка могла быть точно

  • определена парой координат, первым

  • элементом пары всегда является

  • величина Х (абсцисса точки),

  • а вторым элементом – всегда величина

  • У (ордината точки).





Оси координат разбивают плоскость на четыре части, которые называются координатными четвертями.

  • Мы будем работать только в первой

  • координатной четверти



Внимание!

  • Решая задачи с использованием

  • координат, мы не будем пользоваться

  • командами вперед, назад,

  • направо, налево.

  • Новые команды:

  • покажи место – сообщает координаты точки, в которой

  • находиться черепашка;

  • нов_место [х у] – перемещает черепашку в точку

  • с координатами [х у];

  • нов_у число – изменяет у-координату черепашки;

  • нов_х число – изменяет х-координату черепашки;

  • Передвигаясь от точки к точке черепашка может оставлять

  • след, а может не оставлять след.



Пример 1.

  • Построить квадрат, пользуясь координатами его вершин.



Программа на ЛОГО

  • Программа на ЛОГО

  • 2ой вариант:

  • пп

  • нов_место [10 10]

  • по

  • нов_у 60

  • нов_х 60

  • нов_у 10

  • нов_х 10



Пример 2.

  • Даны координаты пятнадцати точек.

  • Построить фигуру по этим координатам.

  • (40,10)

  • (40,20)

  • (10,20)

  • (40,50)

  • (20,50)

  • (40,70)

  • (30,70)

  • (50,90)

  • (70,70)

  • (60,70)

  • (80,50)

  • (60,50)

  • (90,20)

  • (60,20)

  • (60,10)



Черепашка построит:



Пример 3.

  • Даны координаты двенадцати точек.

  • Построить фигуру по этим координатам.

  • (30, 60)

  • (60, 30)

  • (150, 30)

  • (180, 60)

  • (100, 60)

  • (100, 160)

  • (130, 160)

  • (120, 150)

  • (130, 140)

  • (100, 140)

  • (160, 60)

  • (30, 60)



Черепашка построит:



Слышу – и забываю, вижу – и запоминаю, делаю – и понимаю. (Восточная мудрость)





Похожие:

Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconМетодическая разработка по информатике. Тема: «Учебный исполнитель Робот на уроках информатики в 9 классе» Класс: 9 Кол-во занятий: 10
Автор: Вилкова Ольга Юрьевна, учитель информатики высшей категории моу «Лицей №4»
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconОбразовательная программа творческого объединения «Моделирование в среде лого» Срок реализации 1 год Количество участников 10 Лукоянов, 2010 Введение
Лого – это среда программирования и средство для моделирования различных задач и исследований. Сейчас язык лого получил всемирное...
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconМетодическая разработка учителя информатики моу сош с. Яникой Байсултановой Ф. М. Тест (от англ test «испытание», «проверка»). Тестом называют стандартизованные, краткие, ограниченные во времени испытания
...
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconДолжностная инструкция учителя информатики и икт
Учитель по информатике и коммуникационным технологиям определяет общее видение процесса обучения информатики, выполняя следующие...
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconЭкономическая информатика. Приблизительные названия (после перевода на русский язык) предметов, за которые ответственна кафедра
Институте Теоретической и Прикладной Информатики факультета Прикладной механики и Информатики Политехники Ченстоховской
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconКомпьютерная поддержка школьного курса информатики и икт
Стандарты курса информатики и икт требуют от учителя глубоких знаний в профессиональной области, но немаловажно и владение современными...
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconПоложение о кабинете информатики
Данный документ регламентирует требования к учебно-методическому обеспечению кабинета информатики и икт, документации и является...
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconМинистерство образования и науки РФ государственное образовательное учреждение высшего профессионального образования
Сообщаем вам, что 08 декабря 2010 года в 10: 30 на базе факультета информатики кгпу им. В. П. Астафьева состоится Краевой форум информатики,...
Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconДокументы
1. /Страуструп - Язык программирования С++/CHAP000.TXT
2. /Страуструп...

Начала информатики. Алгоритмический язык программирования лого. Методическая разработка презентация учителя информатики Солодовниковой Т. Я iconПриказ №221 ст. Павловская
«Современный курс информатики в общеобразовательном учреждении» (письмо гоу ккидппо от 29 марта 2010 года №01-20/850 «О проведении...
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов