Операции над выделенным текстом: оформление шрифтами icon

Операции над выделенным текстом: оформление шрифтами



НазваниеОперации над выделенным текстом: оформление шрифтами
страница3/4
Дата конвертации16.09.2012
Размер0.5 Mb.
ТипДокументы
1   2   3   4
1. /computer3/15-1.doc
2. /computer3/15-2.doc
3. /computer3/15-3.doc
4. /computer3/16.doc
5. /computer3/18.doc
15. Популярный текстовый редактор Microsoft Word
Операции над выделенным текстом: оформление шрифтами
Печать
16. Электронные таблицы Excel
18. Электронная почта, телеконференции и прочая электросвязь

Таблицы




Эта кнопка служит для создания таблиц. С ее помощью можно создать пустую таблицу, а также преобразовать в таблицу выделенный текст.

Одной кнопкой?

Да, одной, и это вполне логично. Если в тексте не выделен фрагмент, то встав­ляется пустая таблица: выбираете количество строк и столбцов — и готово (вспом­ните рис. 15.10). Теперь можно вводить в нее текст, переходя в следующую ячей­ку клавишей Tab.

Если же был выбран некоторый текстовый фрагмент, то при нажатии этой кнопки он сразу преобразуется в таблицу, причем по умолчанию в качестве раз­делителей Word использует Enter, точку, иногда — точку с запятой, табулятор.

Если Word пытает­ся по умолчанию ис­пользовать не тот раз­делитель, который вы имели в виду, зайдите в меню Таблица (Table) и обратитесь к коман­де Преобразовать в таб­лицу (Convert Text to Ta­ble). В секции Разде­литель (см. рис. 15.34) надо будет поставить точку в нужный вам кружок.






Рис. 15.34. Преобразование текста в таблицу: надо задать вид разделителя, а также количество столбцов и строк


Если выбрать Другой, то нужно будет ввести в окошечке, какой именно «другой».

После того как таблица создана, в меню на месте команды Преобразовать в таб­лицу вы увидите обратную команду — Преобразовать в текст.

В Word 97 в меню Таблица появилось подменю Преобразовать, состоящее из двух строк. Как они называются? Правильно, Преобразовать в таблицу и Преоб­разовать в текст.

В большинстве версий Word'a таблица появляется без рамки, с одной только пунктирной сеткой, по умолчанию — шириной во всю строку. Теперь можно за­няться ее оформлением. Все необходимые для этого команды находятся в меню Таблица и на панели Таблицы и границы.

Word имеет неплохой набор стандартных стилей оформления таблиц.
Коман­да Автоформат таблицы позволит разом оформить всю таблицу по одному из образцов. Причем в отдельном окошечке вам покажут пример оформления этим сти­лем. Просто-таки можно ни о каком оформлении уже и не думать. Если вас впол­не устраивают стандартные возможности, можете дальше эту главу не читать.

Менять ширину и высоту ячейки позволяет команда Высота и ширина ячейки (Word 6-8) или Свойства (9, 10). Но проще делать это мышью. Причем можно двигать границы ячеек, строк и столбцов в самой таблице, а можно — соответству­ющие им движки на координатной линейке.

• Чтобы поменять ширину колонки, надо взяться мышью за правую ее гра­ницу (или за соответствующий движок координатной линейки) и отодви­нуть на нужное расстояние.

• Чтобы поменять высоту строки, надо взяться мышью за ее нижнюю грани­цу (или за тоненький серый движок на вертикальной координатной линей­ке, отмечающий нижнюю границу строки) и подвинуть вверх или вниз.

• Чтобы поменять ширину ячейки, надо взяться мышью за правую или ле­вую ее границу и подвинуть в нужную сторону. Она подвинет соседей и уве­личится (уменьшится).

• Чтобы изменить общую ширину таблицы, тащите левую границу таблицы (или левый ограничитель на координатной линейке).

Правда, в Word 2000 последняя регулировка переделана. Здесь левая граница, так же как и правая, меня­ет только ширину колонки. А ширину и высоту таблицы можно поменять, потащив квадратик в правом ниж­нем углу таблицы (см. рис. 15.35).






Рис. 15.35. Меняем ширину таблицы в Word 2k и ХР


Квадратик в левом верхнем углу по­зволяет свободно перемещать по ли­сту всю таблицу.

С выделенной ячейкой, строкой, столбцом или всей таблицей возможны раз­личные операции редактирования и оформления. А как, кстати, выделять? Для этого предназначены команды Выделить строку, Выделить столбец и Выделить таб­лицу. Удобнее, впрочем, пользоваться мышкой.

• Выделить одну ячейку — щелкнув в левой ее части, рядом с линией сетки, там, где курсор превращается в стрелочку.

• Выделить строку — щелкнув левей ее.

• Выделить столбец — щелкнув по верхней кромке таблицы. Или щелкнув мышью при нажатой клавише Alt.

• Если, не отпуская кнопки, двигать мышь в любую сторону, можно выделить несколько соседних ячеек, строк или столбцов для их совместного оформ­ления. Выделять ячейки не подряд не разрешается.

• Выделить всю таблицу — дважды щелкнув левей ее с нажатой клавишей Alt.

Можно выделять и с клавиатуры — как обычный текст, держа нажатой клавишу Shift. Вся таблица выделяется комбинацией Alt-5 (5 — на цифровой клавиатуре) в отличие от Ctrl-5 (выделяется весь текст).

В любых выделенных ячейках можно поменять шрифтовое и абзацное оформ­ление текста, назначить рамки и линейки, задать цвет шрифта и фона и т. д. На­деюсь, после того как вы прочли четыреста страниц этой книги и почти пятьдесят страниц в этом разделе, для вас уже не составляет секрета, как все это делается.

Выделенные ячейки можно объединить в одну (Таблица-Объединить ячейки), и, наоборот, разбить каждую ячейку на заданное количество частей, можно уда­лять строки, столбцы и отдельные ячейки — на все это есть команды в меню Табли­ца. Если добавить к этому возможность в индивидуальном порядке менять шири­ну ячейки и высоту строки, становится ясно, что Word позволяет создать таблицу самой прихотливой формы.



Начиная с Word 97 таблицу можно даже нарисовать. Карандашиком (панель Таблицы и границы) рисуется рамка таблицы, в ней проводятся сколько угодно каких угодно вертикальных и горизонтальных линий. А ласти­ком все лишние линии стираются.

Чем отличается таблица в Word'e от настоящей электронной таблицы? Толь­ко тем, что в настоящей электронной таблице возможны вычисления: скажем, цена из одной колонки умножается на взятое из другой колонки количество продан­ных штук того, чего тут продают, а в третьей колонке сам собой возникает доход продавца. В Word'e этого нельзя.

Впрочем, вру, можно!



Если нажать кнопку Добавить таблицу Excel и выбрать начальный размер таблицы, то вы получите в вордовском документе кусочек настоящей элект­ронной таблицы. В таблице этой можно будет производить разнообразные и до­вольно сложные вычисления, а также строить диаграммы.

Приглядевшись повнимательнее, вы поймете, что без лишнего шума и пыли оказались в Ехсеl'е (не выходя из Word'a), о чем свидетельствуют изменившиеся меню и панели инструментов. Вот это я понимаю — интеграция!

Вплотную электронными таблицами мы займемся в следующем разделе. А пока еще не все премудрости Word'a нами освоены.

Стили и шаблоны

Документ — это стиль. А. Башмачкин, чиновник

Стиль это человек. Ж. Бюффон, литератор

Человек — это звучит гордо. Сатин, бомж

Внимательные читатели, конечно, заметили, что, рассказывая в прошлых главах об инструментах панели Форматирование, я старательно не обращал внимания на первое слева окно-список, в котором на рисунке 15.1 написано Нормальный. Кто же такой «нормальный» сидит в этом окне? В этом окне сидит стиль.

Стили символьные и стили абзацные

Если перейти в окно стилей мышью или по комбинации Ctrl-Shift-S (Style) и открыть список (рис. 15.36), то мы увидим весь набор заготовленных для нас стилей оформления абзацев — заголовочных (Заголовок 1, Заголовок 2, Заголовок 3) и для ос­новного текста (Нормальный (или Обычный), Основной шрифт абзаца).





Рис. 15.36. Стандартные стили (с нестандартным оформлением)


Начиная с 97-го Word'a в этом списке вы сразу видите, каким шрифтом и какого разме­ра, какими рамками, цветами, пульками, нуме­рацией и проч. оформится абзац или текстовый фрагмент, если вы ткнете мышкой в эту строку. В сереньком квадратике справа указано также выравнивание абзаца и размер шрифта.

Просто ткнув мышью в один из них, мы ра­зом оформим весь абзац или группу выделен­ных абзацев.

Текст оформится единым шрифтом, кеглем и начертанием, отступами, интервалами, выравниванием, позициями табуляторов, даже рамками и линейками — всем тем, что мы рассматривали выше. Такие стили и называются стилями абзаца.

Есть и другая разновидность стиля — стиль символа. Такой стиль меняет за­данным образом только шрифтовое оформление выделенного текста, но не влия­ет на всякие отступы, выравнивание, интервалы. На нашем рисунке вы видите только один такой стиль — Основной шрифт абзаца.

Абзацные стили помечены, чтобы мы не путались, значком Enter , а символь­ные — значком а.

Оформление текста мы можем как угодно менять с помощью команд меню Формат или кнопок панели Форматирование. Но, отменив все символьное фор­матирование (Ctrl-пробелом), мы вернемся именно к тем установкам, которые за­даны для данного стиля. А посему, вот вам еще одни афоризм (не только о компь­ютерах): «Стиль — это то, что остается, когда все остальное уходит» (А. Левин, поэт и гражданин).

Для отмены абзацного оформления пользуйтесь комбинацией Ctrl-Shift-N: фраг­менту будет присвоен стиль Обычный (Нормальный).

В Word XP в окошке стилей не только пишут название, но и некоторые осо­бенности оформления, как, например, на рисунке 15.2. Там написано: NB+Перед: 12 пт, т. е. стиль называется NB, плюс к этому сделан отступ 12 пунктов от преды­дущего абзаца. Если выделен фрагмент, то будет написано, например, Обычный+полужирный. Так вы сразу видите, оформлен данный абзац стандартным образом или на стиль наложено какое-то дополнительное форматирование. Вот именно это дополнительное и отменяют Ctrl-пробел и Ctrl-Shift-N.

Если в параметрах Word XP на странице Вид поставить галочку в строке По­мечать несоответствия формата, то эта версия текст-процессора станет подчерки­вать синей волнистой линией те абзацы, в которых имеется дополнительное фор­матирование.

Изменение существующего и создание нового стиля

Возникают два вопроса. Первый: можно ли менять стили оформления, если они нас не устраивают, создавать новые, если нам мало старых. И второй: можно ли использовать разные наборы стилей. И на оба вопроса один ответ — да.

Все дела по решению первого вопроса поручены команде Стиль (Style) из меню Формат. На рисунке 15.37 вы видите ее основное окно.





Рис. 15.37. Диалоговое окно команды Формат-Стиль


Чтобы поменять стиль оформления, нажмем кнопку Изменить... и попадем в окно с изменения стиля (см. рис. 15.38).






Рис. 15.38. Был стиль Обычный, станет необычный


В нем нас сейчас интересует Формат — кнопка со стрелочкой, что мы привычно воспринимаем как список. И действи­тельно, список того, что можно изменить, появится, едва мы ткнем в эту стрелоч­ку мышкой. Выбирая строки Шрифт, Абзац, Табуляция, Граница, Язык, Рамка или Нумерация (для создания любых списков — и с номерами, и с пулями), мы ока­жемся в знакомых уже окнах оформления выделенного текста.

Меняем любые параметры оформления в любом из этих окон. Потом нажима­ем ОК и вновь попадаем в окно Изменить стиль. Теперь можно выбрать другую строку и поменять другие параметры.

Для быстрой разметки тек­ста этим стилем можно задать для него горячую клавишу - кнопка Клавиша (на рисунке 15.38 в правом нижнем углу).

Нам осталось решить, долж­ны ли внесенные в стиль изме­нения коснуться всех докумен­тов, с которыми мы работаем, или только данного. Когда я задавал в своем Word'e для ра­боты над этой книгой шрифт Петербург 10-го кегля для ос­новного текста, выравнивание по ширине и красную строку, я поставил галочку в квадра­тике Добавить в шаблон. И до­бавил. И теперь у меня всегда Петербург, 10-й кегль и вырав­нивание по ширине!

Галочка в строке Обновлять автоматически позволит вам менять стили прямо из доку­мента. Так, изменив с помо­щью наших обычных кнопок и списков шрифт или выравни­вание какого-то абзаца, помеченного данным стилем, вы сразу же поменяете оформление и для всех остальных абзацев этого стиля.

Если же вы хотите оставить себе воз­можность задать для абзаца индивиду­альное оформление, не меняя при этом стиль, галочку тут не ставьте.

Для изготовления нового стиля надо

в окне Стиль (рис. 15.37) вместо кнопки Изменить нажать кнопку Создать, в сле­дующем окне ввести новое имя и опреде­лить, будет ли это стиль абзаца или только стиль символа. Остальное — аналогично. Учтите только, что всякий создава­емый вами стиль основан на каком-то стиле из числа стандартных (окошко Основан на стиле). Если вы что-то поме­няете потом в родительском стиле, то соответственно поменяются и все дочки и сыночки.


Для удаления ненужного стиля выберите его в окне Стиль и нажмите кнопку Удалить. Удалять стандартные стили (Обычный (Нормальный), Заголовок 1 и т. д.) нам не разрешено.

В Word XP по команде Стили и форматирование слева появляется панель, где вы сможете и поменять стиль, и создать новый, и даже, чего раньше было нельзя, выделить по всему документу абзацы, этим стилем оформленные (рис. 15.39).





Рис. 15.39. В области задач Word XP находится панель Стили и форматирование


Кстати, такая команда появилась и в контекстном меню фрагмента.

Библиотека стилей

А теперь о том, как поменять весь набор стилей. Нужно воспользоваться командой Библиотека стилей в меню Формат. По ней нам будет показан большой-преболь­шой список готовых к употреблению стилевых наборов (шаблонов). В отдельном окне Word сразу покажет, как будет выглядеть наш документ, если мы выберем тот или иной из них. В качестве образца программа может использовать ваш до­кумент или собственный заранее приготовленный пример — брошюру, письмо, факс, техническое описание, служебную записку и т. д. и т. п...

Выбираем подходящий шаблон и жмем ОК. Что при этом произойдет? А вот что. Скажем, у нас был стиль Заголовок 1 и у них в шаблоне тоже Заголовок 1. Но у нас для заголовка выбран был шрифт Arial 14-го кегля и центровка строк, а у них Тайме 18-го и выравнивание влево. После присоединения набора у нас тоже ста­нет Тайме, 18 и влево. И так для всех одноименных стилей. Если же у нас были стили собственного производства с нестандартными именами, то они останутся в целости и сохранности.

Понятно, что для эффективного применения стилевых наборов оформлять свой текст надо в основном стилями со стандартными именами.

Хранятся стилевые наборы в файлах с расширением dot (document template, шаблон документа) — тех самых, которые Word предлагает нам на выбор при со­здании нового файла (см. главу «Новый документ»). Кроме стилей в шаблонах могут храниться собственные наборы макрокоманд, настройки панелей инстру­ментов, списки горячих клавиш, списки автозамены (см. главу «Автозамена и Автотекст») и некоторые другие сведения.

Создание шаблона

Весьма удобен такой метод работы с нестандартными стилями, которым пользу­ются некоторые люди часто и помногу работающие с Word'oм. Для разных нужд они делают свои собственные шаблоны. А начиная работу с новым документом, создают его сразу же на основе нужного шаблона, чтобы документ унаследовал от него все стилевые настройки.


Порядок действий может быть, например, такой.

1. Создаете новый пустой файл (командой Файл-Создать, щелчком по значку Создать или клавиатурной комбинацией Ctrl-N).

2. Изменяете в нем стандартные стили так, как вам это требуется, создаете но­вые, меняете формат бумаги и поля (Файл-Параметры страницы), задаете нумерацию страниц, колонтитулы и т. д. и т. п. При этом собственно текста никакого в документе вводить не надо.

3. Сохраняете файл как шаблон документа: Файл-Сохранить как, тип файла: Шаб­лон документа (*.dot), и даете ему имя. Этот шаблон попадает в глубоко спря­танную папку с таким примерно адресом Windows\Application Data\Microsoft\ шаблоны. Или с таким: Program Files\Microsoft Office\Templates. Или даже вот с таким: Documents and Settings\User\Application Data\Microsoft\Шaблoны, где User — ваше имя. Короче, куда-то попадет. И будет всегда вам доступен.

4. Создавая новый документ командной Файл-Создать, выбираете значок сво­его шаблона и дважды по нему щелкаете.

Можно также присоединить этот шаблон к уже созданному файлу — коман­дой Библиотека стилей, но тогда не все ваши настройки будут автоматически вос­произведены. Например, размеры страницы и поля останутся прежними.

Присоединяя к файлу шаблон командой Библиотека стилей, вы иногда можете не увидеть своего нового шаблона. Просто введите его название (а может быть, придется ввести и полный адрес, если вы куда-то не туда его сохранили). Посмотреть, где ваш Word хранит свои шаблоны, вы можете в параметрах программы на странице Расположение.

Если присоединение шаблона не приводит к изменению оформления, выполните команду Шаблоны и надстройки в меню Сервис. В его диалоговом окне выберите, какой именно шаблон должен присоединяться к документу, и поставьте галочку в строке Автоматически обновлять стили.

Не забывайте также, что при присоединении шаблона все уникальные и не­повторимые стили сохраняются. То есть присоединив к документу по очереди несколько шаблонов, вы можете иной раз получить такой длинный список «уни­кальных» стилей, что работать с ним станет неудобно. Придется лишние убирать вручную, причем по одной штучке.

Впрочем, вручную и по штучке — это только из окна Формат-Стиль. Но в этом окне есть одна кнопочка, о которой мы пока не упоминали. Называется она Орга­низатор (на рисунке 15.37 она слева внизу). Вот этот самый органайзер позволит все сильно ускорить.

В диалоговом окне Организатора (см. рис. 15.40) мы получаем возможность ухаживать за своим стилевым файлом: удалять из него ненужные стили (выделить несколько и нажать кнопку Удалить), переименовывать их (кнопка Переимено­вать), копировать в него стили из любого шаблона (из правого окошка в левое), перенести свой стиль в другой (из левого окошка в правое), хоть во всеобщий стан­дартный Normal.dot.

Кнопочка Закрыть файл убирает шаблон из окошка и тут же заменяется кно­почкой Открыть файл.






Рис. 15.40. Диалоговое окно Организатор


Поосторожнее с общим для всех документов файлом Normal.dot. Лучше работать со своими собственными шаблонами, не трогая общего особенно если вы не один им пользуетесь.

Поиск и замена

Чтобы отыскать в тексте нужное слово или выражение, можно воспользоваться командой Найти в меню Правка или комбинацией Ctrl-F (find — найти). В окне поиска (см. рис. 15.41) задаете текст, который надо найти, направление поиска (вперед — от текущего положения курсора до конца текста, назад — отсюда до начала, или везде, по всему тексту — список Где) и жмете на кнопку Следующее (Найти далее) столько раз, сколько нужно, чтобы просмотреть все интересующие вас фрагменты.





Рис. 15.41. Поиск текста в Word 7


Даже выйдя из окна поиска и проделав какие-то другие операции, вы сохраняете возможность продолжить поиск, когда вам это вновь понадобится. Стоит нажать ком­бинацию Shift-F4, и Word найдет следующее (предыдущее) подходящее выражение. Комбинации Ctrl-PgUp и Ctrl-Dn продолжают поиск вперед и соответственно назад.

Начиная с Word 97 окно поиска стало заметно проще (см. рис. 15.42).






Рис. 15.42. Поиск в Word 97/2000/XP


Правда, есть кнопочка Больше, которая увеличивает окно и достает на свет божий кучу дополнительных возможностей. Но об этом чуть ниже.


Кнопка Заменить в окне поиска переводит нас в окно замены (см. рис. 15.43).





Рис. 15.43. Поиск с заменой в Word 7


Это же окно появится по команде Заменить (Replace) в меню Правка и по комби­нации Ctrl-H.

Здесь появилась новая строка Чем (Заменить на), куда мы будем вводить текст для замены. Появились также две новые кнопки — Заменить (т. е. заменить сле­дующее и перейти дальше) и Заменить все.

Если вы не настолько уверены в том, что делаете, чтобы сразу, не думая, бабах­нуть по кнопке Заменить все, то сперва все же нажмите кнопку Найти следующее, посмотрите, что там Word отыщет и надо ли найденное менять, и только тогда жмите на кнопку Заменить.

Когда нужно что-то из текста удалить, оставьте строку Чем (Заменить на) пус­той. Чаще всего такой заменой чего-то на ничто пользуются для удаления спец­значков — символов конца абзаца, табуляторов и т. п. (см. ниже).

В 8-10 Word'e окно Найти и заменить выглядит несколько иначе: оно объем­ное, трехстраничное. На первой странице — поиск, на второй — замена, а на тре­тьей — переходы (об этом см. в главе «Прочие полезные умения Word'a»).

На рисунке 15.44 вы видите, каким становится окно Найти и заменить в Word 2000, когда нажата кнопка Больше (после этого на ее месте появляется кнопка Меньше).





Рис. 15.44. Поиск и замена в Word 2000


В Word'e действует такой мощный поисковый механизм, как поиск по маске. Для этого применяются символы подстановки: * (любое количество любых сим­волов), ? (один любой символ), < (начало слова), > (конец слова) и некоторые другие.

Например, по маске к?т вы найдете «кита» и «кота», а по маске к*т — еще и «крота», «фокстрот» и даже «кто». Кит и кот будут найдены и по маске <к??> в числе всех трехбуквенных слов на букву К.

Но чтобы такой поиск был вам доступен, надо поставить галочку в квадратик с загадочным названием Использовать шаблон (в Word 8-10 — Подстановочные знаки), разрешающий применение этой прогрессивной методы. В противном слу­чае, Word считает эти знаки просто символами, которые ему надлежит найти и заменить.

Когда кроме обычного текста нужно отыскать невидимые значки (вроде конца абзаца, табулятора или неразрывного пробела) или специальные символы (тире, мягкий перенос, неразрывный дефис), вставленную в текст графику, сноску или примечание, нажмите кнопку Специальный (имеется в виду специальный символ).

Появится большой список разного рода объектов, которые можно найти и заме­нить. Выберите в нем то, что вам нужно, и увидите в строке Что или Чем специ­альный символ, обозначающий этот объект. Здесь будут и ^? (любой символ), ^# (любая цифра), ^$ (любая буква), и конец абзаца ^р, и табулятор ^t, и неразрыв­ный пробел ^s, и проч.

Поиск и замена оформления

Теперь обратите внимание на кнопку-список Формат в окнах Найти и Найти и за­менить. С ее помощью можно отыскать стиль, шрифтовое или абзацное оформление (например, только отцентрованные абзацы, или только слова, выделенные курсивом) и кое-что еще.

Нажав кнопку Формат, мы увидим список того, что можно найти (см. рис. 15.45).






Рис. 15.45. Word позволяет искать и заменять шрифтовое и абзацное оформление


Строка Шрифт выводит нас в знакомое окно шрифтов, Абзац — в знакомое окно оформления абзацев и т. д.

Выберем здесь, к примеру, строку Абзац, зададим выравнивание по центру, жмем ОК и Следующее (Най­ти далее). Тут же Word находит центрованный абзац и выделяет его.

Так же просто можно заменить одно оформление другим. Скажем, понадобилось нам отцентрованные: строки по всему тексту заменить выровненными впра­во. Для этого встаем в строку Найти (Что), выбираем в списке Формат строку Абзац и задаем выравнивание по центру. А потом встаем на строку Заменить на (Чем) и задаем выравнивание вправо. Сами строки Найти и Заменить должны остаться пустыми, иначе мы не сможем обработать все отцентрованные строки. Остается щелкнуть по кнопке Заменить все.

Так же точно все фрагменты, оформленные символьным стилем Толстый корич­невый, можно переоформить символьным стилем Большой и толстый. Или удалить все подзаголовки, оформленные абзацным стилем Заголовок 3. Или для всех ри­сунков в рамках сменить способ обтекания их текстом.

Все можно, осталось только придумать, зачем.. Вот вам жизненный пример. В тексте, который я загрузил в Word из только-тек­стового файла, все английские слова, вроде Microsoft, Word или Windows, помечены как русские, отчего программа проверки орфографии считает их ошибочными, а программа создания переносов не понимает, как их переносить. Делаю замену про­сто «Windows» на «Windows» с форматированием «английский (США)» (задается строкой Язык), потом то же — для Word, для Microsoft и т. д. И все приходит в норму,

Проверяем правописание

В Word'e всех версий имеется встроенная программа проверки орфографии, а в русифицированных она умеет работать и с русским языком. В шестом Word'e рус­ский спеллер был глуповат, в последующих стал заметно понятливее, хотя по-прежнему не без маленьких глюков. Например, слова «треугольник» и «перекладина» он понимает, а «треугольничек» и «перекладинка» нет. Самое удивительное, что спеллер Word'a даже в новейших версиях, не понимает своих собственных терминов: названия пунктов меню Автозамена, Автоформат или Гиперссылка для него абсолютно непонятны (Word XP уже понимает слово "гиперссылка", спасибо большое!). Зато Word (кроме шестого) умеет сразу, по мере набора, находить незнакомые

лова и подчеркивать их красной волнистой чертой. А грамматические ошибки

лишние и пропущенные запятые, отсутствие согласования слов, заглавной бук­вы в начале предложения) Word, начиная с версии 97, подчеркивает зеленой вол­нистой чертой. Правда, проверка грамматики дает пока многовато ложных срабатываний. Ведь здесь от программы требуется кое-что понять, а это уж посложнее,

ем проверить, есть слово в словаре или нету.

Тех, кого подобная услужливость Word'a раздражает, никто насильно кормить ею не будет. Тут у нас полная демократия. Заходим в окно Сервис-Параметры-Орфография и ставим галочку в строку Не выделять слова с ошибками. И все дела.

Проверить можно будет и потом.

Увидев свою ошибку, мы можем даже сами ее не поправлять, предоставив это дело Word'y. Про­сто щелкнем по этому слову правой кнопкой мыши или встанем на него курсором и нажмем клавишу Context, а если у вас на клавиатуре такой нет — комбинацию Shift-F10, Появится такая примерно менюшка, как на рисунке 15.46.





Рис. 15.46. Контекстное меню спеллера: таинственное «мнею» заменяем на обыкновенное «меню»


Выбрав здесь нуж­ный вариант написания, тыкаем в него мышкой. Слово тотчас исправится. Правда, к выражениям уж совсем ни на что не похожим Word замены не подберет.

Чтобы быстро перейти к следующему неопоз­нанному слову, можно дважды щелкнуть по кноп­ке с перелистываемой книжечкой в информаци­онной строке Word'a.

Если же подчеркнутое спеллером слово на самом деле правильное, то можно занести его в словарь (строка Добавить, Add), и тогда оно всегда будет опознаваться.

Но добавив в словарь, например, слово «Сидорчук», на слове «Сидорчуку» мы снова запнемся. В силу своей малой образованности Word не может определить, что такое «Сидорчук» — глагол, наречие или прапорщик, а потому не может правиль­но опознать и производные слова. Существуют и более продвинутые системы провер­ки, в которых вас сначала подробно расспросят о вводимом слове, все про Сидорчука узнают и всегда будут правильно определять его различные грамматические формы.

Если же слово правильное, но вносить его в словарь вы не хотите, выберите строку Пропустить все. В текущем сеансе работы оно будет считаться правиль­ным. А словарь не будет перегружен случайными «сидорчуками», что скажется на быстродействии спеллера.

Строка Орфография открывает основное окно проверки правописания, в кото­ром список вариантов может быть гораздо длиннее. (Напоминаю, все, что я рас­сказал вам насчет контекстных меню, не относится к Word 6.0.)



Проверка правописания во всех версиях Word запускается нажатием этой кнопки, клавиши F7 или командой Орфография (Правописание, Spelling and Grammar) в меню Сервис (Tools).

Найдя слово, отсутствующее в словаре, спеллер остановится и покажет такое примерно окно (см. рис. 15.47).






Рис. 15.47. Проверка орфографии


«Нет в словаре» — слова «полсе». Предлагаемая замена — «после» и куча иных вариантов. Выберите нужный из списка и нажмите кнопку Заменить или Заме­нить все (все подобные ошибки в данном тексте будут заменены без лишних во­просов). Спеллер внесет исправления и пойдет дальше.

В новых версиях Word не просто показывает найденное слово, он показывает его вместе с предложением, где оно стоит, чтобы вы могли понять, о чем там идет речь и чем следует заменить ошибочное слово.

Кнопками Пропустить или Пропустить все разрешаем спеллеру не обращать на него внимания.

Кнопка Автозамена (в 6.0 — Автокоррекция) внесет выбранную пару (ошибочное слово и правильное, выбранное из предоставленных вариантов) в список автомати­ческих замен. И теперь слово «полсе», возникавшее ранее на каждой странице по три раза минимум, никогда уже не появится в вашем изумительно грамотном тексте,

Хочу вас предостеречь от чрезмерного доверия к программам проверки ошибок: они не всесильны. Я, например, при наборе постоянно теряю букву «п» в слове «по­просят». Но в результате получается слово «поросят», которое спеллер совершенно справедливо не считает ошибкой. Так что если вы сами внимательно не перечитаете свой текст (за меня-то корректор старается!), то в нем может оказать­ся какая-нибудь смешная нелепица вроде: «после этого вас поросят...».

В Word 97 строка Автозамена появилась уже и в контекстом меню слова с ошибкой (см. рис. 15.48). Это я считаю глубоко верным ре­шением и активно применяю при написании всяческих самоучителей.





Рис. 15.48. Автозамена в контекстом меню Word 2000


Посмотрев список предложенных замен, выбираете нужное слово (если оно там есть!) и жмете на Enter.

Словари пользователя

А что делать, если вы ввели в словарь ошибочное слово? Бывает, особенно с ус­татку. Неужели навсегда застряло в словаре какое-нибудь дурацкое «соотвествующий»? Должно же быть средство эту бяку удалить!

На самом деле мы вносим слова не в основной, а во вспомогательный, пользо­вательский словарь. В отличие от сложно устроенного основного это обычный текстовый файл. Если найти его, то не составит особого труда загрузить его в любой виндоузовский редактор и поправить ошибки.

Где хранятся ваши словари, може­те посмотреть в параметрах Word'а (Сервис-Параметры) на странице Расположение.

Но можно не прибегать ни к ка­ким дополнительным редакторам и ничего на диске не искать: пользова­тельские словари разрешается пра­вить прямо в Word'e.

В многостраничном окне пара­метров Word'a на странице Орфог­рафия (Правописание) есть инте­ресная кнопочка Словари. Нажав ее, вы увидите (см. рис. 15.49), ка­кие пользовательские словари у вас используются и где они располо­жены.





Рис. 15.49. Вспомогательный словарь и путь к нему


Например, я в своем 2000-м Word'e использую два расположенных в разных местах вспомогательных словаря с именем custom.dic (так исторически сложилось). Но это вовсе не обязательно. Ненужный словарь можно отключить, убрав галоч­ку возле его строки. Где расположен словарь, можете посмотреть в строке Путь.

Чтобы поправить ошибку, загрузим словарь в Word (кнопка Изменить), попра­вим, что надо, и сохраним.

На время внесения исправлений в пользовательский словарь автоматическая проверка ошибок отключается. Когда закончите чистку словаря, сохраните его и закроете его окно (Ctrl-F4), надо будет снова зайти на страницу Орфография (Пра­вописание) и снова поставить галочку в строке Автоматически проверять орфог­рафию.

Кстати, сохранить словарь можно и в другую папку. А когда потребуется, под­ключить кнопкой Добавить. Так можно из одного длиннющего словаря можно создавать компактные словарики по разным темам, не перенапрягая без необхо­димости вордовский спеллер.

Язык

Начиная с версии 7.0 Word стал уже настолько умным, что понимает, когда слова написаны по-русски, а когда — по-английски, и применяет к ним разные словари.

Организовано это следующим образом. Каждое слово в тексте помимо шриф­тового форматирования имеет еще одно — языковое форматирование. Выделив фрагмент (или весь текст) и задав команду Язык (Language) в меню Сервис, мож­но выбрать из списка русский, английский или иной язык. И тогда фрагмент бу­дет считаться русским (английским, иным каким-нибудь), и Word попытается применить к нему соответствующий словарь.

Если же словаря для выбранного языка, скажем малайского, у вас в системе нет, выберите строку Без проверки в самом верху списка, и вас, по крайней мере, не станут донимать сообщениями о мнимых ошибках, на обработку которых может и памяти не хватить.

Учтите только, что комбинация Ctrl-пробел, отменяющая все виды шрифтово­го оформления, отменит и присвоенный язык. Word «забудет», что это слово анг­лийское или малайское, и вновь подчеркнет волнистой чертой.

Для правильной работы с русскими текстами в качестве основного языка системы должен быть выбран русский. Если этого не сделать, Word (б и 7) будет считать оши­бочными все русские слова и вскоре вообще откажется проверять ошибки по причине нехватки памяти. Горю этому помочь нетрудно. Выберите в меню Сервис команду Язык (Выбрать язык), найдите строку Русский и нажмите кнопку По умолчанию.

Но самое ценное то, что Word при наборе текстов сам размечает русские и ан­глийские слова и выражения. Когда вы вводите текст в русской раскладке клави­атуры, он помечается как русский, а когда переключаетесь на английский, весь последующий текст будет запомнен как английский.

Одна только ошибка совершена разработчиками. Перейдя с английского на русский, вы должны продолжать вводить текст подряд. Стоит вам просто отойти курсором в сторону (даже ничего не редактируя) и вернуться, как вводимый рус­ский текст шибко умный Word станет считать английским и подчеркивать. Сде­лайте этому тексту Ctrl-пробел.

При переходе с русского на английский все обстоит точно так же неудобно. Мне даже пришлось сделать макрокоманду для оформления выделенного фраг­мента как английского.

В контекстном меню ошибочного слова в Word 2000 появилась еще одна но­вая строка — Язык (см. рис. 15.48), что позволит нам быстро исправить весьма рас­пространенную в двуязычных текстах ошибку. Причем верхним в списке окажется язык, принятый как основной (у нас это будет русский). А если вы пометили в тексте какое-то слово как английское, то Word самостоятельно перенесет вверх списка строку английский (США), что, конечно, весьма мило с его стороны.

Кстати, так же услужливо ведут себя 2000-й и ХР и в отношении некоторых других настроек. Скажем, в списке шрифтов в верх списка выносятся названия последних использованных шрифтов. Казалось бы, ерунда, но при длинном спис­ке установленных гарнитур необыкновенно ускоряет дело. Точнее даже не уско­ряет, а облегчает, бережет наши нервы и глаза.

Автозамена и Автотекст

Некоторые самые распространенные ошибки набора Word знает и будет сам их исправлять. В числе таких типичнейших опечаток — строчная буква в начале предложения, вторая большая БУква в начале слова, случайное нажатие клави­ши CapsLock (ПРИВОДЯЩЕЕ К ТОМУ, что заглавная буква оказывается строч­ной и наоборот).

Экзотическое слово «каемнь» Word молча заменит на более привычное «ка­мень», а (с) — на знак копирайта ©. Список таких замен вы можете посмотреть в окне команды Автозамена (AutoCorrect, Автокорреция) в меню Сервис (Tools) (см. рис. 15.50).






Рис. 15.50. Теперь вместо «полсе» всегда будет «после»


Заодно можно внести в этот список и свои типовые очепятки с опетачками: слева в окошке Заменить: вводится неверное написание, справа в окошке На: — верное, а затем нажимается кнопка Добавить.

Не забудьте только ввести для слова самые распространенные его формы (па­дежи-времена-числа). А не то выражение «полседний» будет исправлено, а «полседние» возьмет и не будет.

У седьмого-десятого Word'a список автоматических замен, введенный для нас умными дядями и тетями, заметно длиннее, чем у шестого. Желание его сократить (особенно, если вы сами что-то в него ввели неправильно) легко выполнимо: отыс­киваете нужную пару и жмете на кнопку Удалить.

Word XP ведет разные списки автозамен для русских и английских слов. В какой список вы попадете по команде Сервис-Параметры автозамены зависит только от того, каким языком помечено слово, в котором вы стоите.

Еще одно огромное удобство команды Автозамена: возможность ее использо­вания для ввода сокращений. Я научил свой Word заменять «ком.» на «компью­тер», «вв.» на «Word», «вин.» на «Windows», «мо.» на «Microsoft Office», a «coo.» на «соответствующ» (окончание я уж, так и быть, вписываю сам). Выражения с латинскими буквами особенно здесь уместны, ибо переключаться с русского на английский и обратно почему-то всегда лень.

Но учтите, что английские слова, введенные прямо в список, Word будет счи­тать русскими (при условии, что именно этот язык установлен в системе по умол­чанию) и подчеркнет красной волнистой чертой. Тут надо поступить иначе: пря­мо в тексте выделить нужное английское слово или целое выражение и ввести команду Автозамена. Выделенный фрагмент попадет в правую строку (На:). Ос­тается добавить его сокращение в левое окошко (Заменить:) и, главное, поставить точку в кружок Форматированный текст. Вот теперь Word запомнит слово с его форматированием, включая и язык, и все слова будут вставляться верно.

Таким способом вы сможете вставлять целые абзацы (до 255 символов длиной) вместе со шрифтовым и абзацным форматированием — шрифтами, языком, вы­равниванием, рамками, отступами. Более того, если в выделенном тексте находил­ся рисунок, он тоже будет вставляться!

Замечательно, что когда я пишу «ком.», возникает слово «компьютер», а когда «Ком.» — «Компьютер» без всякого моего участия. Более того, написав «ком.» после точки, я получаю «Компьютер» — с большой буквы: соображает, скотина!

Если встретившееся в тексте слово «Инциндент» не ошибочное, хоть и очень, увы, распространенное написание слова «инцидент», а просто такая фамилия («Ю. А. Инциндент, помощник депутата»), то автоматическая замена в данном случае не нужна. Выполните один раз отмену команды (Ctrl-Z), и фамилия вер­нется к своему истинному виду.

По команде Сервис-Автозамена в новых версиях Word'a мы получаем четырехстраничное диалоговое окно, на вкладочках которого значатся страницы Автоза­мена, Автоформат при вводе, Автотекст и Автоформат.

На первой из них мы будем задавать наш список автозамен, на второй опреде­лим, что именно Word будет автоматически форматировать при наборе текста, на четвертой — что он будет форматировать при выполнении высокоинтеллектуаль­ной команды Автоформат (помните значок с лучезарным солнышком в главе «Операции над выделенным текстом: оформление абзаца»?). А на третьей стра­нице будет у нас список элементов автотекста, о котором мы и поговорим сейчас.

Автотекст (AutoText) — другой способ использования сокращений. С помо­щью этой команды можно быстро вставлять в документ текстовые фрагменты, а также картинки, таблицы и иные более или менее часто вами используемые объекты.

Скажем, вам хочется завести сокращение для быстрого ввода длинных рекви­зитов вашей фирмы (адреса, телефоны, номер банковского счета и что там еще пишут) или для помещения на страницу фирменного логотипа. Выделяете в до­кументе текст или рисунок (или и то и другое) и вводите команду Автотекст или нажимаете Alt-F3 (начиная с Word 8).

Выскакивает маленькое окошко Создание элемента автотекста, где вам надо будет написать, к примеру, «адр.», и нажать кнопку ОК. Все, объект ваш попал в список, стал его элементом, как это называется в Word'e.

Может быть, в вашей вер­сии Word'a выскочит не со­всем уж маленькое окно — такое, как на рисунке 15.51.





Рис. 15.51. Адрес будет вставляться в текст по нажатию клавиши F3 вместо слова «адр.»


Но поступать вы будете так же: введете имя элемента и подтвердите свое желание внести его в список — кноп­кой Добавить.

Чтобы теперь вставить элемент списка (хоть в дру­гой файл, хоть через неде­лю), набираете в тексте его имя (в нашем случае — сло­во «адр.») и нажимаете кла­вишу F3. Адрес тут же встав­ляется вместо имени.

Важно только, чтобы имя элемента стояло отдельно от других слов, через про­бел, иначе Word не поймет, что мы имеем в виду.

В новейших версиях Word'a вставлять элемент автотекста еще проще. Едва вы наберете «адр.», как Word покажет вам желтенькую подсказочку с продолжени­ем. Если это то, чего вы хотите, нажмите Enter, и все вставится. Но можно продол­жать набор, не обращая никакого внимания на эту услужливую подсказку, и она, опечаленная, пропадет.

Имена всех элементов помнить необязательно — те, которые вы будете часто использовать, запомнятся сами, а остальное вы всегда можете посмотреть непос­редственно в списке элементов автотекста (рис. 15.51). Выделите нужную строку и нажмите кнопку Вставить.

В Word 8-10 эта операция дополнительно упрощена. В меню Вставка имеется подменю Автотекст, в выпадающем списке которого вы и найдете названия всех элементов.

Замечательные команды Автотекст и Автозамена! Возникает один только глу­пый вопрос: почему их две, если они делают одно и то же? Неужели все дело толь­ко в том, что одна работает автоматически, а другая по клавише F3, у одной есть ограничение на размер вводимого фрагмента, а у другой нет?.. Пишите нам, доро­гие телезрители, за самые интересные ответы вам будут вручены потрясающие призы от фирмы Microso...
1   2   3   4



Похожие:

Операции над выделенным текстом: оформление шрифтами iconУроки №3-4 тема: " Программирование линейных алгоритмов. Стандартные математические функции Паскаля. Модуль crt". Основные операции в Паскале
В тп 0 все операции делятся на: математические, логические, операции с символами и строкам, операции над множествами, операции отношения,...
Операции над выделенным текстом: оформление шрифтами iconОперации над нечеткими числами
Целый раздел теории нечетких множеств – мягкие вычисления (нечеткая арифметика) вводит набор операций над нечеткими числами. Эти...
Операции над выделенным текстом: оформление шрифтами iconТранспортная экспедиция: документальное оформление, бухучет и налогообложение
Из этой статьи вы узнаете о том, какими документами оформляются эти операции, как избежать ошибок при отражении операций в бухгалтерском...
Операции над выделенным текстом: оформление шрифтами iconЗанятие Условные операторы. Переменные с плавающей точкой и операции над ними. Логический тип. Интервальный тип

Операции над выделенным текстом: оформление шрифтами iconЗанятие Структура программы. Переменные. Операторы ввода-вывода. Оператор присваивания. Целочисленные переменные и операции над ними

Операции над выделенным текстом: оформление шрифтами iconОперации над нечеткими подмножествами
А и В, результатом которой является множество с = а  В, которое содержит только те элементы, которые принадлежат и множеству a и...
Операции над выделенным текстом: оформление шрифтами iconНечеткие последовательности, нечеткие прямоугольные матрицы, нечеткие функции и операции над ними
Нечеткая последовательность – это пронумерованное счетное множество нечетких чисел
Операции над выделенным текстом: оформление шрифтами iconДокументы
1. /algor/3D-2D.txt
2. /algor/3D.doc
Операции над выделенным текстом: оформление шрифтами iconНечеткие числа и операции над ними
Выделим два терм-множества значений: T1 = «U у лежит в диапазоне примерно от a до b» с нечетким подмножеством М1 и безымянное значение...
Операции над выделенным текстом: оформление шрифтами iconПлан работы отряда «Волонтёр» (для детей группы соп)
Открытие лагеря, оформление аудитории, разделение на группы, оформление газеты своей группы, самопрезентация, самопредставление,...
Операции над выделенным текстом: оформление шрифтами iconЗалік папки: тексти, малюнки, ярлики
Створіть у папці тексти текстовий документ анкета. Doc І напишіть розповідь про себе. Оформіть різними шрифтами І кольорами. Визначте...
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов