Каркасные, поверхностные и твердотельные icon

Каркасные, поверхностные и твердотельные



НазваниеКаркасные, поверхностные и твердотельные
Дата конвертации10.09.2012
Размер130.6 Kb.
ТипДокументы
1. /acad14/Lab01.doc
2. /acad14/Lab02.doc
3. /acad14/Lab03.doc
4. /acad14/Lab04.doc
5. /acad14/Вопросы для подготовки к госэкзамену Информатика и ОКТ для архитекторов.doc
6. /acad14/Задания-2003.doc
7. /acad14/Контрольная работа по основам Автокад (2005).doc
8. /acad14/Памятка AutoCAD.doc
Тема Основы работы в Autocad
Тема Основные примитивы и команды Autocad
Тема Виды и видовые экраны, пск, изометрия, слои
Каркасные, поверхностные и твердотельные
Вопросы для подготовки к экзамену по курсу «Информатика и основы информационных технологий»
Acad14
Контрольная работа по основам Автокад, вариант 1 Контрольная работа по основам Автокад
Формат. Лимиты Размеры чертежа




Тема 4. ПОСТРОЕНИЕ ТРЕХМЕРНЫХ ОБЪЕКТОВ В AutoCAD


Трехмерные объекты можно разделить на каркасные, поверхностные и твердотельные. Каркасные модели напоминают модели, сделанные из проволоки. Они не несут информации о поверхностях и объеме реального объекта, но полезны при начальном создании моделей, которые потом можно преобразовать в поверхностные или твердотельные. Поверхностные модели хранят информацию о поверхностях, формирующих реальный вид объекта, и таким образом позволяют воспроизводить определенные оптические свойства, например, закрывать объекты, расположенные позади них. Твердотельные модели (тела) несут информацию об объеме, который занимают реальные моделируемые объекты. Можно комбинировать тела, объединяя и вычитая их, и создавать таким образом модели достаточно сложных объектов.


Для перехода к трехмерным (3М) координатам достаточно к формату 2М координат добавить значение Z. Например, вместо ввода координат точки 2,5, можно ввести 2,5,3. Введенная точка находится на расстоянии 3 ед. над плоскостью X,Y на оси Z. Ось Z проходит через начало координат 0,0,0, перпендикулярно осям X и Y и направлена прямо на пользователя, и соответственно, отрицательная часть оси Z - в противоположном направлении. Такой вид является по умолчанию исходным видом в Мировой Системе Координат (МСК).


Если пользователь работает в плоскости, то вводимые им точки автоматически помещаются в пространство 3М с координатой Z равной нулю. При этом Автокад помещает точки в плоскости X,Y текущей Пользовательской системы координат (ПСК). Управлять положением координаты Z можно, создавая ПСК, расположенные выше или ниже плоскости X,Y Мировой системы координат (МСК). Кроме того значения Z можно задавать путем привязки точки к существующим объектам или при помощи координатных фильтров.

Чтобы ввести 3М координату напрямую, достаточно ввести ее значение в формате X,Y,Z. Можно также воспользоваться сферическими и цилиндрическими координатами.

Сферические координаты вводятся в формате (расстояние<угол<угол), где расстояние измеряется вдоль вектора, исходящего из точки 0,0,0. Первый угол есть наклон вектора к оси X в плоскости X,Y, а второй угол - наклон к плоскости X,Y (выше плоскости -положительный; ниже плоскости - отрицательный).

Цилиндрические координаты задаются в формате (расстояние<угол, расстояние). В данном формате первое расстояние измеряется вдоль вектора от точки 0,0,0; угол равен наклону вектора к оси X в плоскости X,Y; второе расстояние равно проекции точки на ось Z. Чтобы ввести точку в относительных 3М координатах, следует добавить в формат знак @, например, @2,5,3. Относительные сферические и цилиндрические координаты ,например, могут быть @3<45<60 и @4<60,3.

Начало 0,0,0 текущий системы координат, которой по умолчанию является МСК, называется глобальным или мировым началом. Большинство примитивов Автокада создаются в ориентации текущей ПСК.


Управляя ориентацией ПСК и ее началом, можно поместить любой объект в любую точку и под любым углом в пространстве. ПСК можно уподобить стеклу, на котором можно рисовать. Обычно стекло лежит на столе. Когда же что-то нужно нарисовать в другом плане, стекло перемещается, поворачивается или наклоняется так, чтобы получить нужную ориентацию, и закрепляют его в этом положении. Этот план (обычно плоскость X,Y текущей ПСК) называется текущим. В Автокаде положением и ориентацией осей ПСК и текущего плана можно манипулировать командой ucs (ПСК).

Запрос команды ПСК имеет вид:

Начало/ZОсь/3точки/Объект/Вид/X/Y/Z/Предыдущ/Замени/Сохрани/Удали/?/<Мир>:

Опции команды ПСК.

Начало - задает новое начало ПСК без изменения ориентации.

ZОсь - задает новое начало и переориентирует ось Z.

3точки - задает новое начало ПСК, точку на положительном направлении оси X и точку на положительном направлении оси Y.

Объект - задает ПСК путем указания на объект.

Вид - устанавливает ПСК таким образом, что плоскость X,Y поворачивается только параллельно плоскости экрана.

X - задает новую ПСК путем поворота осей Y и Z вокруг оси X.

Y - задает новую ПСК путем поворота осей X и Z вокруг оси Y.

Z - задает новую ПСК путем поворота осей X и Y вокруг оси Z.

Предыдущ - восстанавливает предыдущую ПСК (можно восстановить в обратном порядке до 10 предыдущих сохраненных ПСК).

Замени - запрашивает имя определенной ранее ПСК и делает ее текущей. Если ввести "?", то на экран выводится весь список сохраненных ПСК.

Сохрани - присваивает имя и сохраняет текущую ПСК. Для получения списка сохраненных ПСК необходимо ввести "?".

Удали - удаление указанной ПСК из списка сохраненных.

? - выводит список сохраненных ПСК (текущая неименнованная ПСК отображается в списке под именем "БЕЗ ИМЕНИ").

<Мир> - выбирается по умолчанию и восстанавливает Мировую систему координат.

Для наглядного представления ориентации текущей ПСК используются пиктограммы ПСК. Обычно пиктограмма представляет собой две взаимо перпендикулярные стрелки, совпадающие с положительным направлением осей X и Y и обозначенных, соответственно, X и Y . Пиктограмму обычно помещают в начало ПСК.

Приведем основные формы пиктограммы ПСК:

1) М. Буква М на стрелке Y появляется тогда, когда текущая ПСК совпадает с МСК.

2) +. Знак плюс появляется в пересечении стрелок X и Y, если пиктограмма находится в начале ПСК.

3) Квадрат. На пересечении стрелок X и Y появляется квадрат, если точка зрения лежит выше плоскости X,Y ПСК. Квадрат пропадает, если вы рассматриваете ПСК снизу от плоскости X,Y.

4) Квадрат со сломанным карандашом. Стрелки X и Y заменяются на квадрат со сломанным карандашом, если плоскость X,Y текущей ПСК повернута кромкой (или почти кромкой) к точке зрения пользователя.

5) Куб в перспективе. Куб в перспективе заменяет стрелки X,Y, когда вы рассматриваете рисунок в перспективе.

Команда ПЛАН (plan) позволяет получить вид рисунка сверху любой определенной ПСК или МСК. Точка зрения при этом перемещается в точку 0,0,1 указанной ПСК. Запрос команды ПЛАН: <Текущая ПСК>/ПСК/Мир:

Если вы потерялись в трехмерном пространстве, используя команду ПСК, то вам необходимо восстановить МСК (вид в плане, команда Сервис.ПСК.МСК).


КОМАНДА 3М ТЗРЕНИЯ (меню Вид.3М Тзрения.Выбрать) задает трехмерную точку зрения или направление и угол, под которым вы рассматриваете рисунок. По умолчанию это вид сверху, рассматриваемый с точки 0,0,1 текущей ПСК. Простейший способ задать точку зрения - это использовать один из вариантов выбора в падающем меню Вид.3М ТЗРЕНИЯ. Все они используют опцию Поверни.


ОБЪЕКТНАЯ ПРИВЯЗКА В 3М ПРОСТРАНСТВЕ И КООРДИНАТНЫЕ ФИЛЬТРЫ

Если вы работаете в трехмерном пространстве, то привязку к объекту необходимо выполнять очень внимательно, особенно если объекты перекрывают друг друга на текущем виде, но занимают различное положение в пространстве. В этом случае пользуются координатными фильтрами, которые позволяют использовать компоненты координат существующих точек для построения новой точки. Можно использовать любую комбинацию существующих значений X,Y,Z с новыми значениями, введенными с клавиатуры. Например, на любой запрос Автокада ввести точку вы вводите .XY (или .X, .Y, .Z, .XZ, .YZ). При этом Автокад считывает значения, соответственно, координат X и Y указанной вами точки. Затем система запрашивает значение оставшейся координаты Z и комбинируя эти три значения образует новую точку в трехмерном пространстве. Можно вызывать фильтры также из командного меню (Shift + правая кнопка мыши).


Упражнение 13. Работу в трехмерном пространстве покажем на примере построения каркасного чертежа стола (выполните этот пример, сохранив результат работы в файле 10.dwg). Ниже приведены команды и координаты для рисования каркасной модели стола:

Прямоугольник, координаты 0,0 и 39,15

Копировать, выбрать прямоугольник, указать в качестве базовой точки один из углов, ввести величину смещения @0,0,2

Меню Вид, 3D виды, ЮЗ изометрия (теперь видны оба прямоугольника)

Отрезок, объектной привязкой Конточка указать левый верхний угол верхнего прямоугольника и провести линии со смещениями (@0,0,-30), (@2,0,0), (@0,0,30)

Копировать, выбрать 3 только что нарисованных отрезка, копированием создать остальные ножки стола.

Сохраните нарисованный объект как блок с именем table.

Вставьте в чертеж новый блок table.

Масштаб, выбрать новый объект table, базовая точка смещения – с помощью режима Конточка указать нижнюю точку ножки стола, ввести величину масштаба 0.5

Создайте аналогично приведенному образцу изображение стула со спинкой, с размером сиденья 15*15. Для скругления углов спинки используйте команду Сопряжение. Сохраните стул как блок chair


КОМАНДА ВЫСОТА (окно свойств объекта )

Большинство пространственных моделей можно построить, просто располагая плоские объекты в различной ориентации и "выдавливая" их с необходимой толщиной. Такие объекты выглядят совершенно как трехмерные. Выдавливать можно отрезки, полилинии, дуги, круги и фигуры, придавая им определенную высоту. Если высота положительная, то объект выдавливается в положительном направлении оси Z. Отрицательная высота приводит к выдавливанию в отрицательном направлении оси Z. Изменить высоту существующего объекта можно в окне СВОЙСТВА.


Для размещения объектов в пространстве друг относительно друга (например, чтобы поставить один объект на другой) им придается уровень, который становится координатой z. Для вновь создаваемых объектов это можно сделать командой elev (уровень) – после нее все создаваемые объекты будут помещаться на указанный уровень по оси z. Командой move (перенеси) можно перенести уже существующий объект вдоль оси z.




Упражнение 14. С помощью придания объектам высоты создайте цилиндр, равнобедренную треугольную пирамиду, куб и параллелепипед, высота и ширина которого равны между собой и вдвое меньше длины. Командой hide (скрой) скройте невидимые линии. Вернитесь к каркасной модели командой regen (реген). Обратите внимание, что одни объекты снабжаются верхней гранью автоматически (круги, полилинии с шириной, объекты, созданные командой solid (фигура)), а другие – нет.


Упражнение 15. Создайте по образцу 3-мерный чертеж кабельной катушки. Здесь высота катушки=24, она приведена в проекции ЮВ изометрия.


Упражнение16 - пример построения объекта с использованием граней: создать новый документ, установить Архитектурные единицы измерения.

Команда ЗМ ГРАНЬ панели Поверхности, ввод пар координат <6,6>, <@20,0>, <@0,2’>, <@-20,0>,

Команда КОПИРУЙ, выбрать нарисованную плоскость, ответить Н(есколько) на запрос базовой точки, указать любую точку в качестве базовой, вторая точка – <@0,0,1.5’>, <@0,0,3’>, .

К
1

2
оманда Вид->3М Тзрения->ЮВ Изометрия (стали видны 3 поверхности – полки шкафа)

Постройте 2 стенки шкафа командой ЗМ ГРАНЬ (на рисунке нужные грани закрашены).

Добавьте к чертежу новый слой, установите в слое цвет, отличный от черного и нарисуйте в нем дверцу. Для этого проведите отрезок от точки 1 на со смещением @18<225, скопируйте отрезок в точку 2 (вспомогательные линии нарисованы). Выберите команду Сервис->ПСК->3 точки, в качестве начала координат укажите левую конечную точку нижней вспомогательной линии, затем точку 2, затем левую конечную точку верхней вспомогательной линии. Система координат изменена.

Включить режим ОРТО, команда ОТРЕЗОК, выбрать в контекстном меню чертежа опцию СМЕЩЕНИЕ, показать в качестве базовой левую конечную точку верхней вспомогательной линии, ввести смещение <@3,-3>, переместить курсор вправо и ввести 12, переместить курсор вниз и ввести 30, переместить курсор влево и ввести 12, ввести з (замкни) – окошко в дверце нарисовано.

Вернуться в слой 0, с помощью команды 3М ГРАНЬ нарисовать на дверце шкафа 4 поверхности, отделяющие видимые края дверцы от прозрачного окошка. Командой КРОМКА панели Поверхности удалить угловые ребра поверхностей на дверце. Перейти к мировой системе координат командой Сервис->ПСК->МСК. Повернуть шкаф – для этого обратиться к команде Вид->3М Тзрения->Выбрать, ввести в окне диалога угол от оси X 200 градусов, угол с плоскостью XY 35 градусов. Командой Вид->Скрыть удалить невидимые линии с чертежа. Результат должен соответствовать рисунку – сквозь окошко в дверце видны полки внутри шкафа.


Упражнение 17. Пользуясь представленным образцом, создайте 3-мерный чертеж дома из каркасных линий и поверхностей. Размеры выбрать самостоятельно.

Рекомендации: нарисовав верхние контуры стен с помощью прямоугольников, можно затем придать им высоту. Окна также удобней нарисовать на виде сверху, придать им высоту, вдвое меньшую высоты стен, затем перенести командой ПЕРЕНЕСТИ в направлении оси Z на высоту, равную четверти высоты стен. Перейдя к трехмерному виду и соединив противоположные углы дома временной линией, можно нарисовать линию вверх по оси Z от ее середины и затем привязать к получившейся верхней точке чертежа линии, формирующие контур крыши. Чтобы построить поверхность по линиям контура крыши, воспользуйтесь кнопкой 3М ГРАНЬ панели «Поверхности». После этого инструменты РАСКРАСИТЬ и ТОНИРОВАТЬ панели Тонирование должны раскрашивать и крышу (см.рис).

Помните, что вернуться к «каркасному» представлению модели можно командой РЕГЕН


Упражнение 18. Используя команды панели инструментов Тела (в меню – Рисование->Тела) и операции над телами (Редакт -> Логические операции, Редакт->3М операции) создайте объекты, изображенные на рисунках:










Комментарии:

Объект 1 получен выдавливанием окружностей, построением и сдвигом шара и удалением невидимых линий. Высота в его ножки в архитектурных единицах равна 3’

Объект 2 получен построением куба, построением и сдвигом шара и затем вычитанием из куба шара. Размер стороны куба в архитектурных единицах равен 2’, диаметр шара равен 1’.

Объект 3 получен командой Поверхность вращения панели Поверхности (помните, что для вращения нужно задать один вращаемый объект и определить ось, вокруг которой оно происходит). В примере вращаемый объект был построен на плоскости командой Полилиния (треугольник) и затем повернут на 900 относительно плоскости XY

Объект 4 построен с помощью команды Поверхность сдвига панели Поверхности, умеющей сдвигать выбранный контур или профиль вдоль отрезка в пространстве, определяющего направление и расстояние выдавливания, при этом получается трехмерная сеть из полилиний. В примере при виде на чертеж сверху был построен сплайн по 4 точкам, определен отрезок с координатами (0,0,0), (0,0,1’), служащий направляющим вектором, и в проекции ЮЗ Изометрия выполнен сдвиг.

Объект 5 построен с помощью команды Поверхность соединения панели Поверхности, умеющей связывать два объекта (отрезки, 2-мерные и 3-мерные полилинии, окружности, эллипсы, дуги, сплайны и точки). Точкой может быть только 1 из объектов. В примере с помощью полилинии был построен квадрат со стороной 1’, по его 3 его углам построен прямоугольный треугольник и сдвинут на 1’ по оси z. Затем по этим 2 телам построена поверхность соединения.

Качеством отображения поверхностей управляют изменяемые системные переменные surftab1 и surftab2 (чем больше их значения, тем точнее аппроксимируются поверхности).


Переменные, влияющие на отображение твердотельных моделей:

Отображение всех криволинейных поверхностей в чертеже регулируется с помощью системной переменной isolines. Ее значение по умолчанию равно 4, что составляет допустимый минимум кривых, позволяющих оценить форму криволинейной поверхности. При этом значении отображение происходит наиболее быстро. При увеличении значения качество отображения криволинейных поверхностей увеличивается, но скорость вывода уменьшается. Переменная isolines действует только при отображении каркасной модели.

Переменная facetres (диапазон значений – от 0.01 до 10.0, по умолчанию 0.5) влияет на отображение криволинейных поверхностей и тел после использования команд hide (скрой), shade (тень), render (тонируй).

Переменная dispsilh определяет, будет ли создаваться контурное представление объемной модели, базирующееся на текущем направлении проецирования. При значении 1 при каркасном отображении модели отображаются только линии силуэта. Значение по умолчанию равно 0.


Упражнение 19. Используя тела и логические операции над телами, создайте объект по образцу на рисунке (объект показан тонированным). После отрисовки деталей объект должен быть объединен в единое целое.

Комментарии: Для создания внешнего контура модели использовано вычитание 2-х цилиндров. Аналогично можно получить центральную цилиндрическую насадку. Для создания пластины с отверстиями также использован цилиндр, из которого вычтены 6 кругов, полученных созданием кругового массива и затем использованием команды Выдавить панели Тела.

Внешний радиус объекта при настройках чертежа по умолчанию равен 120 единицам, высота равна 40, высота пластины основания равна 5, радиус отверстий в пластине равен 15.

Скопируйте объект и с помощью инструментов панели Тела получите рисунок объекта в разрезе.

С помощью инструментов панели Тонирование добавьте на чертеж источники света, фоновое изображение, заливку текстурой.

Дополнительные упражнения по теме.



1. Нарисовать половину бокового контура лампы командой «Полилиния»

2. Создать объект в пространстве командой «Поверхность вращения» панели «Поверхности».

3. Повернуть объект командой Редактирование.ЗМ Операции.3М Поворот так, чтоб лампа стояла на плоскости XY

4. В виде ЮЗ Изометрия или ЮВ Изометрия лампа выглядит, как на рисунке.

Постройте тем же способом изображение пепельницы






Объект справа получен рисованием квадрата, сопряжением его смежных сторон и затем сдвигом вдоль вектора, направленного перпендикулярного плоскости квадрата (команда «Поверхность сдвига» панели «Поверхности»). Обратите внимание, что поверхность строится только вдоль вектора сдвига, внутри объект остается полым и может потребоваться команда ЗМ Грань для заполнения его верхней и нижней граней.






Постройте объект с использованием поверхности сдвига






Для построения этого объекта использована команда Выдавить (Рисование.Тела или панель инструментов Тела). Сначала рисуется дуга верхнего контура в половину окружности, концы дуги соединяются отрезком, дуга и отрезок объединяются в область, затем получившаяся область выдавливается на 100 единиц с коэффициентом сужения –5 градусов. Аналогично можно получать объемные тела вращением областей (команда Вращать).



Основная часть объекта получена построением конуса и разрезанием его секущей плоскостью (команда Сечение панели инструментов Тела). Отверстие получено построением цилиндра и вычитанием его из основного объема тела.



Для рисования кронштейна используйте выдавливание верхней поверхности на рисунке. Отверстия в кронштейне эллиптические, радиусы эллипса соотносятся как 2:1, а расстояния до краев кронштейна равны меньшему из радиусов.




Дом на рисунке получен только с помощью инструментов панели «Тела» и операций вычитания и объединения тел. Обратите внимание на подоконники и ниши под ними с обратной стороны.

Добавьте в отдельном слое крышу. Сделать лампу на стене источником освещения. Закрасьте и тонируйте объект.






Похожие:

Каркасные, поверхностные и твердотельные iconМировой океан крупнейший природный комплекс планеты
Поверхностные течения: изобразить схемы течений в контурных картах каждого океана
Каркасные, поверхностные и твердотельные iconДокументы
1. /Юхани Кепо Деревянный дом каркасные работы от фундамента до крыши.doc
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы