Практическое занятие 10 icon

Практическое занятие 10



НазваниеПрактическое занятие 10
Дата конвертации14.09.2012
Размер70.99 Kb.
ТипПрактикум



Практикум по Word. Занятие 10: слияние документов

Практическое занятие 10.

Работа с текстовым процессором MS WORD:
использование слияния и полей



Цель работы:

  1. Освоение способов слияния документов

  2. Использование в документе полей Word.

Основные понятия:
слияние документов, источник данных, сортировка и фильтрация.



1. Слияние документов в Word

Слияние документов – операция, позволяющая включить в основной документ информацию из другого источника (базы данных, таблицы).

Для выполнения операции слияния необходимо иметь:

  • основной документ, содержащий постоянную информацию, а также поля, в которые при слиянии помещаются переменные данные;

  • источник данных, содержащий переменные данные.






С помощью слияния подготавливают рассылки, почтовые конверты, письма, каталоги и т.п. документы, в которых можно выделить постоянную и переменную часть.

Источником данных может служить:

- базы данных (например, Access);

- электронные таблицы (например, Excel);

- документы Word;

- текстовые файлы и другие.

В любом случае, источник данных должен включать строку заголовка, с наименованиями каждого поля, и набор однотипных записей, например:


Фамилия

Имя

Отчество

Город

Улица

Дом-квартира

Иванов

Иван

Иванович

Иваново

Ивановская

5-46

Петров

Петр

Петрович

Петропавловск

Питерская

12-129

Васильев

Василий

Васильевич

Тула

Ф.
Энгельса

4-415


Для слияния документов необходимо выполнить следующие шаги:

  • создать или открыть основной документ;

  • создать или открыть источник данных;

  • вставить в основной документ поля слияния, которые будут заменяться значениями полей каждой записи базы данных;

  • объединить документы.

Слияние документов производится с помощью команд Сервис – Слияние … (Сервис - Письма и рассылки – Мастер слияние) и с помощью кнопок панели инструментов Слияние:




2. Задания

2.1. Подготовить рассылку извещений следующего содержания:

г Город Улица д. Дом Квартира


Уважаемый Имя Отчество Фамилия !

Напоминаем, что до начала экзаменационной сессии

группы Индекс группы специальности Наименование специальности

осталось меньше двух месяцев.

С уважением ТФ РМАТ.


Выделены поля, которые в каждом письме должны быть заменены значениями из источника данных.

В процессе создания рассылки следует обратить внимание на средства сортировки и отбора (фильтрации) записей источника данных.


2.2. Порядок выполнения задания:

2.2.1. Проверьте, что сброшен режим показа кодов полей: команда меню Сервис – Параметры, на вкладке Вид в разделе Показывать должен быть удален флажок Коды полей.

2.2.2.Создайте новый документ Word, содержащий таблицу с полями:

Фамилия

Имя

Отчество

Город

Улица

Дом-квартира

Индекс_группы

Специальность

Иванов

Иван

Иванович

Иваново

Ивановская

5-46

080104

Маркетинг

















































В таблице должно быть не менее 5 записей, специальности и индексы групп должны различаться.

Сохраните документ в своей папке, как Источник-1.doc и закройте его.

2.2.3. Создайте новый документ Word, содержащий заготовку извещения, сохраните его как Извещение1.doc.

2.2.4. Активизируйте панель Слияние.

Кнопкой Настройка главного документа задайте тип документа - Письма.

Кнопкой Открыть источник данных вызовите диалог выбора источника, найдите и откройте Источник-1.doc.

С помощью кнопки Вставить поля слияния вставьте в основной документ необходимые поля слияния.

Кнопкой Поля/Данные переключите отображение полей на отображение значений и обратно.

В режиме отображения данных изучите действие кнопок навигации: Первая запись \ Последняя запись, Предыдущая запись \ следующая запись, Поиск элемента

2.2.5. Кнопкой Слияние в новый документ создайте объединенный документ, просмотрите созданные письма и сохраните файл рассылки под именем Результат1.doc.

Обратите внимание, что каждое письмо создается на отдельной странице.

2.3. Создайте новый документ Word. Создайте новую рассылку с помощью команды меню Сервис – Письма и рассылки – Мастер слияния (Сервис – Слияние) и повторите формирование рассылки, создавая и сохраняя основной документ (Извещение2.doc) и источник данных (Источник-2.doc) в процессе слияния и сохраните документ с рассылкой под именем Результат2.doc.

Указание. Источник формируется как список получателей удалением и добавлением необходимых полей.

2.4. Изучите возможности для сортировки и фильтрации писем (Кнопка Получатели панели Слияние или команда Изменить список (Отбор записей) на шаге просмотра писем). Повторите создание рассылки, включив в нее записи только для одной специальности (используйте фильтр по полю «Специальность») и сохраните документ с рассылкой под именем Результат3.doc.


^ 3. Вставка полей Word в результирующий документ

Список «Добавить поле Word» на панели «Слияние» позволяет включать в результирующий документ поля Word. Например, поле Mergerec включает в результирующий документ номер записи базы данных; поле If … Then … Else позволяет включать в документ переменную информацию на основании оценки значения других полей источника.


^ 4. Дополнительное задание

Повторите создание рассылки, включив в текст извещения

- номер записи в базе данных;

- ремарку «Туляк» или «Иногородний», в зависимости от значения поля «Город».

Сохраните документ с рассылкой под именем Результат4.doc.


^ 5. Контрольные вопросы

1. Что такое слияние документов? Как оно выполняется?

2. Как получить результирующий документ, отсортированный по фамилиям получателей? Можно ли получить такой результат, не изменяя источник?

3. Как получить рассылку, адресованную только отдельным корреспондентам из общей базы данных?

4. Для чего можно использовать поле Word “If… Then… Else… “ при слиянии документов?

5. Как производится переключение между режимом просмотра кода полей и режимом просмотра их значений?


^ 6. Материал к следующему занятию

Набор формул; создание списка иллюстраций, перекрестных ссылок; использование элементов автозамены и автотекста.

[I – 207-209; 287-290; 245-256; 335-339] [II – 157-160]


  1. Дополнение. Некоторые отличия интерфейса программы Word-2007 от интерфейса программы Word-2003

    1. Для слияния документов могут использоваться команды вкладки Рассылки.

    2. Слияние можно также выполнить с помощью области задач Слияние, которая позволяет шаг за шагом осуществить весь процесс. Чтобы воспользоваться областью задач, в группе Начать слияние на вкладке Рассылки выберите пункт Начать слияние, а затем пункт Пошаговый мастер слияния







www.alural.narod.ru/inform/intro.htm Александр Ю. Алексеев




Похожие:

Практическое занятие 10 iconИзготовление ватно-марлевой повязки Практическое занятие по обж

Практическое занятие 10 iconПрактическое занятие 9
Освоение способов создания, оформления таблиц и выполнения вычислений в таблицах
Практическое занятие 10 iconПрактическое занятие 5
Получение практических навыков по настройке программы и созданию и редактированию текстовых документов
Практическое занятие 10 iconПрактическое занятие 8
Освоение способов интеграции объектов: вставка в текстовый документ рисунков, созданных в других приложениях
Практическое занятие 10 iconПрактическое занятие 12
Для создания программ на vba в Excel формы и элементы управления используется так же, как и в Word
Практическое занятие 10 iconПрактическое занятие 11
Цель работы: изучение возможностей языка программирования Visual Basic for Application для создания функций пользователя
Практическое занятие 10 iconПрактическое занятие 7
Суммесли(диапазон;критерий;диапазон суммирования) – суммирует ячейки, заданные критерием, аргументы
Практическое занятие 10 iconПрактическое занятие 11
Создайте новый документ, введите текст "Создание формул" и сохраните документ в своей папке под именем Формула doc
Практическое занятие 10 iconПрактическое занятие 6
Откройте созданный на предыдущем занятии документ Tekst doc и перейдите в начало документа, нажав комбинацию клавиш Ctrl+Home. Выведите...
Практическое занятие 10 iconПрактическое занятие «Нестандартные методы решения неравенств. Метод замены функций»
Решение некоторых логарифмических неравенств основано на переходе к новому, не зависящему от переменной, основанию
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов