Знакомство с программой моделирования электронных устройств Workbench 0 icon

Знакомство с программой моделирования электронных устройств Workbench 0



НазваниеЗнакомство с программой моделирования электронных устройств Workbench 0
Дата конвертации02.07.2012
Размер77.86 Kb.
ТипЛабораторная работа
1. /Lab1/Лабораторная работа 1.doc
2. /Lab2/Лабораторная работа 2.doc
3. /Lab3/Лабораторная работа 3.doc
4. /Lab4/Лабораторная работа 4.doc
5. /Lab5/Лабораторная работа 5.doc
6. /Lab6/Лабораторная работа 6.doc
7. /Lab7/Лабораторная работа 7.doc
Знакомство с программой моделирования электронных устройств Workbench 0
Полигармонические сигналы
Спектральный анализ сигналов, используемых в информационно-измерительной технике
Моделирование амплитудно-модулированных сигналов
Моделирование функциональных схем
Моделирование функциональных схем
Преобразование сигналов

Лабораторная работа №1

Знакомство с программой моделирования электронных устройств Workbench 5.0

1. Цель и задачи работы


  1. Ознакомиться с программой моделирования электронных схем Workbench 5.0.

  2. Получить практические навыки создания электрических принципиальных схем и их моделирования.

2. Теоретическая часть


Разработка любого радиоэлектронного устройства сопровождается физическим и математическим моделированием. Физическое моделирование связано с большими материальными затратами.

Пакет программ Workbench предназначен для моделирования электронных аналоговых и цифровых схем. Особенностью программы является наличие контрольно-измерительных приборов, по внешнему виду и характеристикам приближенных к их промышленным аналогам. Программа легко осваивается и достаточно удобна в работе.

Программа Workbench 5.0 имеет стандартный пользовательский интерфейс, принятый в ОС Windows.

Окно программы Workbench 5.0 (рис.1) содержит поле меню, линейку кнопок библиотек компонентов и контрольно-измерительных приборов, рабочее поле программы, поле описания схемы (по умолчанию выключено).







Рис. 1


Все операции в Workbench 5.0 доступны через пункты меню. Кратко опишем основные пункты меню.

Меню File предназначено для загрузки и записи файлов, распечатки схемы или ее части, а также для импорта/экспорта файлов в форматах других систем моделирования и программ разработки печатных плат.


Меню Edit позволяет выполнять команды редактирования схем (копировать в буфер обмена выделенный фрагмент, вырезать в буфер обмена выделенный фрагмент, вставить содержимое буфера обмена на рабочее поле) и копирования экрана.

Меню Circuit используется при подготовке схем, а также для создания параметров моделирования (Schematic Options — редактирование параметров схемы).

Меню Analysis предназначен для запуска и остановки моделирования схемы (пункты Activate, Pause, Stop), редактирования параметров моделирования, а также вывода результатов моделирования на экран (пункт Display Graphs).

Меню Window предназначено для упорядочивания информации в рабочем окне программы и включения окна текстового пояснения к схеме.

Меню Help предназначено для получения помощи по программе. Оно содержит краткие сведения по всем рассмотренным выше командам, библиотечным компонентам и измерительным приборам, а также сведения о самой программе. Необходимо отметить, что для получения справки по библиотечному компоненту, его необходимо отметить на схеме щелчком левой кнопки мыши (он высветится красным цветом) и затем нажать клавишу F1.


Для моделирования схем в Workbench необходимо выполнить следующие подготовительные пункты:

  1. выбор необходимых компонентов;

  2. создание электрических соединений;

  3. редактирование свойств компонентов;

  4. сохранение файла схемы на диске.

Остановимся более подробно на каждом из них.

Выбор необходимых компонентов производится следующим образом. На панели библиотеки компонентов (рис. 2) нажатием соответствующей кнопки выбираем интересующую нас категорию, например Basic (основные).




Рис. 2


Раскроется окно, в котором мы видим компоненты для построения схем. В этой категории присутствуют пассивные компоненты (резисторы, конденсаторы, индуктивности, переключатели и др.). Нажав левой кнопкой мышки на требуемый компонент и не отпуская кнопку переместим его на рабочее поле программы. Получим изображение компонента на рабочем поле программы.

В процессе лабораторных работ нам понадобятся следующие категории:

  1. Sources (источники);

  2. Basic (основные);

  3. Instrument (приборы).

Создание электрических соединений производится следующим образом. Устанавливается курсор мышки в точку откуда необходимо вести электрическое соединение, нажимается левая кнопка мыши и курсор ведется в то место, куда необходимо завести электрическое соединение. Причем местами “куда” и “откуда” ведутся электрические связи должны быть выводы компонентов (при подведении курсора к выводу компонента появляется черная точка), электрические соединения или узлы электрических соединений.

Редактирование свойств компонентов производится двойным щелчком левой клавиши мышки по требуемому компоненту. В результате открывается окно редактирования свойств. На рисунке 3 показано окно редактирования свойств резистора.






Рис. 3

В этом окне имеются закладки Label, Value, Fault, Display, Analysis Setup.

В закладке Value устанавливается значение параметров компонентов, таких как электрическое сопротивление для резисторов, емкость для конденсаторов, индуктивность для дросселей и т. д.

Для того чтобы изменить значение параметра необходимо в окне редактирования свойств компонента в закладке Value в соответствующем поле написать необходимое значение параметра и выбрать единицы измерения.

В закладке Label присваивается название компонента и его обозначение на схеме.

После того, как создали схему электрическую принципиальную ее необходимо сохранить на диске. Для этого в меню File выбираем пункт Save. Появляется диалоговое окно, в котором необходимо указать имя файла и место его расположения. По умолчанию схеме присваивается имя Untitled.

Сохраненную схему можно затем вызвать с помощью меню File/Open.

Создав принципиальную электрическую схему можно приступить к ее моделированию.

Программа Workbench позволяет проводить два вида моделирования: классическое (которое используется в таких программах как PSpise, Micro-Cap V) и моделирование “реальное”, когда используются виртуальные измерительные приборы, такие как осциллограф, вольтметр, амперметр и т. д. Второй метод моделирования является избыточным, так как производит большое количество одинаковых расчетов (так как для многих установившихся периодических процессов необходимо смоделировать один-два периода), поэтому для больших схем может быть не применим. Но этот метод обладает большой наглядностью, поэтому на начальном этапе освоения систем моделирования электронных устройств является наиболее предпочтительным.

“Реальное” моделирование запускается из меню Analysis/Activate. Останавливается командой меню Analysis/Stop, приостанавливается — Analysis/Pause. Кроме того, запускать и останавливать моделирование можно с помощью выключателя в верхнем правом углу окна программы.

После включения “реального” моделирования на виртуальных приборах можно наблюдать значения токов, напряжений в момент времени, которое отображается в самой нижней строке окна.

По классическому методу проводятся виды моделирования, указанные в пункте меню Analysis после пункта Analysis Options... В этом случае мы из пункта меню Analysis выбираем вид моделирования (например Fourier...), после чего появляется диалоговое окно (рис. 4), в котором задаются параметры моделирования и нажимается кнопка ОК. Программа производит необходимые расчеты и выдает результаты расчетов в виде графиков или числовой информации.




Рис. 4



Результаты расчетов можно посмотреть с помощью пункта меню Analysis/Display Graphs выбрав закладку интересующего вида моделирования. После проведения каждого вида моделирования в окне результатов Analysis/Display Graphs появляются новые закладки, с результатами проведенного вида моделирования (рис.5)

Рис.5

Для более удобного восприятия данных с графиков в окне результатов моделирования имеется возможность пользоваться кнопками включения сетки, “легенды” графика (полезно, когда на графике изображаются несколько кривых), а также использовать кнопку Toggle Cursors, которая выводит два курсора, перемещаемых с помощью мышки и с помощью которых можно производить считывание значения ординат кривой в любой точке. Значения координат курсоров по оси Х и значения функции в точке нахождения курсора отображаются в окошке справа.

3. Практическая часть


Для ознакомления с программой Workbench создадим простую схему и проведем моделирование ее.

  1. Вынесите на рабочее поле из группы компонентов Sourses источник постоянного напряжения (Battery) и два обозначения земли (Ground), из группы компонентов Basic три резистора, из группы Transistors биполярный n-p-n транзистор, из группы Instruments осциллограф (Osciloscope) и функциональный генератор (Functional Generator). Необходимо заметить, что при подведении курсора к кнопке через несколько секунд всплывает подсказка, указывающая на назначение кнопки.

  2. Разместите компоненты как показано на рисунке 6. Двигать компоненты по рабочему полю можно щелкнув левой кнопкой мышки по изображению компонента и не отпуская кнопку, передвигать компонент в любую точку рабочего поля. Для того, чтобы повернуть компонент на 45°, отобразить зеркально по горизонтали и вертикали, необходимо щелкнуть один раз по изображению компонента правой кнопкой мышки. Появится контекстное меню, в котором есть пункты Rotate (повернуть), Flip Horisontal (отобразить горизонтально), Flip Vertical (отобразить вертикально). Выбрать необходимую операцию.




Рис. 6


  1. Проведите электрические связи в соответствии с рис.6.

  2. Измените значения параметров компонентов в соответствии со схемой (рис.6). Для того чтобы изменить значение параметров компонента необходимо дважды щелкнуть левой кнопкой мышки по изображению компонента. Появится окно редактирования свойств компонента. В закладке Value в соответствующем поле (для резисторов —в поле Resistance, для источника постоянного напряжения — в поле Voltage) установите необходимые значения.

  3. Разверните функциональный генератор дважды щелкнув по его изображению. В появившемся окне в поле Amplitude установит значение 700 mV

  4. Сохраните изображение схемы с помощью меню File/Save As... Появится диалоговое окно, где в поле Имя файла необходимо написать любое название, по смыслу соответствующее содержанию схемы. В завершение процедуры сохранения необходимо нажать кнопку Сохранить.

  5. Разверните осциллограф, дважды щелкнув на его изображение. Появится окно осциллографа.

  6. Запустите моделирование нажав мышкой на изображение выключателя в правом верхнем углу окна программы.

  7. На экране осциллографа появится изображение сигнала. Произведите изменение его параметров (частоту и амплитуду) пользуясь сеткой на экране осциллографа.

  8. Остановите моделирование нажав мышкой на изображение выключателя в правом верхнем углу окна программы.

  9. Изменяя значения резистора R2 и R3 проследите, как изменяется сигнал на экране осциллографа.



Требования к отчету


Отчет по лабораторной работе должен содержать:

  1. Титульный лист

  2. Цель и задачи работы

  3. Краткие теоретические сведения (ответы на контрольный вопросы)

  4. Результаты лабораторной работы (графики, таблицы, значения параметров измеренных в процессе работы)

  5. Необходимые расчеты (если они оговариваются в практической части лабораторной работы)

  6. Выводы.



Контрольные вопросы к работе:


  1. Для чего используется программа Workbench ?

  2. Что является отличительной особенностью программы Workbench?

  3. Как вводить компоненты на рабочее поле программы ?

  4. Как изменять параметры компонентов схемы ?

  5. Какие “виртуальные” инструменты используются в Workbench ?

  6. Как сохранить схему на диске ?




Похожие:

Знакомство с программой моделирования электронных устройств Workbench 0 iconДокументы
1. /Крибель Х.Схемы любительских электронных устройств.1992.djvu
Знакомство с программой моделирования электронных устройств Workbench 0 iconДокументы
...
Знакомство с программой моделирования электронных устройств Workbench 0 iconСведения об электронных образовательных ресурсах мбоу «Гимназия №29», доступ к которым обеспечивается обучающимся
...
Знакомство с программой моделирования электронных устройств Workbench 0 iconВариант 1 Задание: Общее задание. «Знакомство с учебной программой»
...
Знакомство с программой моделирования электронных устройств Workbench 0 iconУрок №1 Тема урока: Знакомство с электронными таблицами excel. Введение основных понятий и правил работы
Цель урока: Ввести основные понятия excel, показать правила создания простейшей таблицы, объяснить суть и назначение электронных...
Знакомство с программой моделирования электронных устройств Workbench 0 iconСовершенная дизъюнктивная, совершенная конъюнктивная нормальная форма
Мы знаем 2 способа задания логических функций: формулой и таблицей истинности. По формуле легко составляется таблица. На практике...
Знакомство с программой моделирования электронных устройств Workbench 0 iconСписок электронных средств обучения, поступивших в отдел образования в 2010 году
Занятия по интересам. Развитие способностей учащихся на основе электронных дидактических игр. 2-4 классы
Знакомство с программой моделирования электронных устройств Workbench 0 iconДоговор о предоставлении услуги «Электронный дневник» родителю (законному представителю) обучающегося в муниципальном образовательном учреждении
Автоматизированной информационной системы электронных дневников учащихся и электронных журналов образовательных учреждений Пермского...
Знакомство с программой моделирования электронных устройств Workbench 0 iconРегламент проведения VIII чемпионата Приволжского Федерального Округа по шахматам среди мужчин и I первенства Приволжского Федерального Округа по шахматам среди юниоров
Соревнования проходят по швейцарской системе в 9 туров по Правилам фиде с использованием электронных шахматных часов. Жеребьевка...
Знакомство с программой моделирования электронных устройств Workbench 0 iconТренинговая работа занятие первое — «Знакомство» Цель
Цель. Ориентация учащихся в целях тренинга, знакомство с участниками; установление групповых норм; создание рабочей ат­мосферы в...
Знакомство с программой моделирования электронных устройств Workbench 0 iconО мерах безопасности при изготовлении и наладке устройств !
Неосторожное обращение с током в процессе изготовления, наладки и эксплуа­тации устройств может привести к печальным последствиям,...
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов