«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» icon

«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления»



Название«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления»
страница1/10
Дата конвертации30.05.2012
Размер1.2 Mb.
ТипЛабораторная работа
  1   2   3   4   5   6   7   8   9   10
1. /Программирование.doc«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления»


Министерство образования Российской Федерации

Северо-Кавказский государственный технический университет

Кафедра АСОИУ


Методические указания

по курсу

«Программирование на языке высокого уровня»


для студентов специальности 220200

«Автоматизированные системы обработки иформации и управления»


г. Ставрополь

2002г.





Данные методические указания включают в себя 20 лабораторных работ для изучения курса «Программирование на языке высокого уровня». Эти работы помогут студентам освоить как базовые понятия программирования на алгоритмических языках Паскаль и Си (интегрированная среда, программы линейной, разветвляющейся и циклической структуры, процедуры и функции, работа с файлами, графика, динамическая память), так и более сложные вопросы (модули, объектно-ориентированное программирование, программирование в среде Delphi). Включен также материал по основам алгоритмизации, в частности, алгоритмы поиска и сортировки массивов.

В каждой лабораторной работе указывается ее цель, изложены краткие теоретические сведения, приведены примеры программ, на основе которых могут быть разработаны самостоятельные программы согласно вариантам заданий. Ответы на приведенные в методических указаниях контрольные вопросы способствуют закреплению материала.


Составители: Ратнер И.М., Гахова Н.Н, Вельц О.В.Б Шилов А.А.

В.И.


Лабораторная работа № 1

РАБОТА В ИНТЕГРИРОВАННОЙ СРЕДЕ

BORLAND PASCAL

НА ПРИМЕРЕ ПРОГРАММ ЛИНЕЙНОЙ СТРУКТУРЫ


1. ЦЕЛЬ РАБОТЫ: Закрепление знаний об интегрированной среде Borland Pascal; составление, ввод и выполнение простейшей линейной программы.

2. ОСНОВНЫЕ СВЕДЕНИЯ


2.1. Программы линейной структуры

Алгоритм линейной структуры - это алгоритм, в котором блоки выполняются в указанном порядке, последовательно друг за другом. Программа линейной структуры реализует соответствующий линейный алгоритм.


Чаще всего линейные алгоритмы используются для программирования вычислений по формулам.
В этом случае удобно использовать набор встроенных функций Pascal:

Sin (x) – синус х; cos(x) – косинус х; tan(x)- тангенс х ; ln (x) – натуральный логарифм х ; exp (x) -показательная функция ex ; ln (x); sqr (x) - квадрат x; sqrt(x)- корень квадратный от х; abs(x)- модуль x.

Для тригонометрических функций аргумент х измеряется в радианах. Гиперболические функции записываются с применением экспоненты, например: Sh (x)=(exp (x)-exp (-x)) /2

Пример программы линейной структуры

Требуется вычислить высоты треугольника по трем заданным сторонам a, b, c. Для вычисления высот воспользуемся двумя выражениями площади треугольника - по трем сторонам (формула Герона) и как половина произведения стороны на соответствующую высоту:

S=1/2ah ; S=;

здесь p - полупериметр p=(a+b+c)/2. Соответствующая этому алгоритму программа вычисления высот треугольника имеет вид:

program linejn ; {программа вычисления высот треугольника }

var

a, b, c, p, ha, hb, hc, t : real; {описание используемых переменных }

begin

writeln (‘Введите стороны тр-ка a,b,c’);

readln (a,b,c);

p:=(a+b+c)/2.; {вычисление полупериметра треугольника }

t:=2.*sqrt (p*(p-a)*(p-b)*(p-c));

ha:=t/a; hb:=t/b; hc:=t/c; {вычисление высот треугольника }

writeln (‘Высоты треугольника: ha=‘,ha:8:2,’ hb=‘, hb:8:2,’ hc=‘,hc:8:2);

end.

Дадим краткое пояснение. Комментарий в программе на языке Паскаль служит для разъяснения действий основных блоков текста и программы в целом. Комментарий заключается в фигурные скобки {} или в пары символов (* *) и не влияет на компиляцию программы. Это - средство самодокументирования программ.

Процедуры read , write (writeln) служат для ввода с клавиатуры и вывода на экран соответственно. Символы ln в процедуре writeln служат для перевода на новую строку. В программе описаны переменные a, b, c, ha, hb, hc, t вещественного типа (real).

В данной программе из математических функций используется sqrt(x) - квадратный корень из x.

При выводе можно включить общую ширину поля вывода и число позиций после десятичной точки. В данном случае высоты треугольника выводятся в поле из 8 позиций каждая, из которых одна отводится на десятичную точку, а две - на цифры после десятичной точки. Остальные 5 позиций отводятся на знак и целую часть числа. Вывод текста ‘ hb=’ содержит по крайней мере один пробел после первого апострофа для отделения от предыдущего значения. Завершает текст программы оператор end.

Обратим внимание, что в программе вычисляется промежуточная переменная t (удвоенная площадь треугольника), через которую вычисляются высоты. Вычисление такого рода промежуточных переменных для сокращения дальнейших вычислений - характерный признак программ на языках высокого уровня, в том числе Паскаль.


2.2. Общие сведения о интегрированной Среде Borland Pascal


Экраны интегрированных Сред Turbo и Borland Pascal подобны и содержат главное меню, окно редактирования, строку состояния.

Для входа в главное меню следует нажать F10.

Главное меню содержит пункты: File(Файл), Edit(Редактирование), Search(поиск), Run(Исполнить), Compile(Компиляция), Debug(Отладка), Tools(Инструменты), Options(Параметры), Window(Окно), Help(Помощь). Из этих пунктов для нас важнейшими будут File, Edit, Compile, Run, Help.

В меню File имеются пункты Open (Открыть), при помощи которого открывается существующий программный файл, New (Создать) - создается новый файл, Save (Сохранить) - сохраняется редактируемый файл, Save as (Сохранить как) - файл сохраняется под новым именем, Change dir (Изменить каталог) - задаются входные и выходные каталоги. Последним пунктом нужно пользоваться, чтобы задать ваш каталог, где хранятся тексты программ. Пункт Quit(Выход) служит для выхода из Среды. В меню File приведены также “горячие “ клавиши (F3), (F2), (ALT+X) для открытия, сохранения файла и для выхода из Среды соответственно.

В меню Edit имеются пункты Cut (Вырезать), Copy (Копировать), Paste (Вставить), Clear (Очистить), которые служат для вырезания, копирования, вставки и очистки выделенного фрагмента текста, как в любом текстовом редакторе.

Выделение фрагмента текста производится установкой курсора в начале фрагмента, отметкой начала блока (CTRL+K+B), передвижением курсора в конец блока и отметкой конца блока (CTRL+K+K). Вырезание, копирование, вставка фрагмента осуществляются с помощью пунктов меню Edit или с помощью горячих клавиш (Shift+Del), (CTRL+INS), (Shift+INS) соответственно.

Меню Compile содержит пункт Compile(Компиляция), горячие клавиши ALT+F9.

Меню Run содержит пункт Run(Исполнить), горячие клавиши CTRL+F9.

Меню Help позволяет обратиться к подсказке (справочной системе), содержит пункты Contents (Содержание), Index (Предметный указатель) - горячие клавиши (Shift+F1), Topic search (Тематический поиск) - горячие клавиши (CTRL+F1). Подсказкой следует пользоваться для быстрого освоения Интегрированной Среды. Нажатие клавиши F1 приводит к открытию окна подсказки. Для получения справки о конкретной функции следует установить курсор на любой символ заголовка функции и нажать (CTRL+F1).

2.

3. Работа в Среде Borland Pascal

Прежде, чем работать в Среде, следует создать рабочий каталог, в который будут заноситься исходные тексты программ на языке PASCAL. Желательно также иметь дискету для хранения текстов программ. Дискету ОБЯЗАТЕЛЬНО проверять на наличие вирусов. Использование дискеты с вирусами НЕДОПУСТИМО!

Переходим на диск D: в каталог PASCAL. Находим исполняемый файл TURBO.exe или BP.exe и запускаем его (наводим на него курсор и нажимаем ENTER). Входим в меню File (F10 - File - Change dir) и устанавливаем в пункте Input Directory имя нашего рабочего каталога, например C:\STUD-001.


Затем набираем линейную программу, приведенную в пункте 2.1 .

:

  1   2   3   4   5   6   7   8   9   10



Похожие:

«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconЗадания и методические указания к курсовой работе по Системному анализу и исследованию операций для студентов специальности асу
«Автоматизированные системы обработки информации и управления». Она посвящена моделированию, анализу и решению оптимизационных задач,...
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconКубгту кафедра вычислительной техники и асу м. П. Малыхина программирование на языке высокого уровня
Рассмотрен комплекс вопросов, связанных с развитием у студентов навыков создания разнообразных программ. Изучение ведется на конкретных...
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconМетодические указания для студентов специальности Э. 01. 03. 00 «Экономика и управление на предприятии»
Вычислительная техника и программирование. Методические указания для студентов-заочников специальности А. 29. 10. 00 «Строительство...
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconУчебно-методический комплекс по дисциплине «теория бюрократии» (Для студентов, обучающихся по специальности 032001- «Документоведение и документационное обеспечение управления»)
Для студентов, обучающихся по специальности 032001– «Документоведение и документационное обеспечение управления»
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconКурс лекций Преподаватель – Абрамова С. В
Автоматизированные средства управления разработкой (системы управления проектами спу) 9
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconПрограмма по курсу «экологи я» для специальности (ей): (шифр название специальности (ей)) 230201 «информационные системы и технологии» для специализации: (название специализации) «информационные системы»
Гос впо) по специальности 230201 – «информационные системы и технологии», утвержденного 27 марта 2000 г., регистрационный №276 тех/дс,...
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconДокументы
1. /Альбом Автоматизированные системы управления (АУУ).pdf
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconСборник заданий по методам программирования
Целью заданий является: изучение отдельных алгоритмов; их реализация на языке высокого уровня; проведение серии экспериментов, подтверждающих...
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconI основы языка высокого уровня турбо pascal алфавит языка Pascal
Прописные и строчные буквы Pascal'eм не различаются. Знаки «возведение в степень» и двойная кавычка в языке отсутствуют
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconМетодические указания и контрольные задания по курсу «Бухгалтерская финансовая отчетность» для студентов специальности 080109 «Бухгалтерский учет, анализ и аудит»
Методические указания предназначены для студентов дневной и вечерней форм обучения
«Программирование на языке высокого уровня» для студентов специальности 220200 «Автоматизированные системы обработки иформации и управления» iconРабочая программа по курсу «химия» для специальности (ей): 230201. 65 «Информационные системы и новый шифр название специальности (ей) технологии» для специализаций
«Южно-Российский государственный технический университет (Новочеркасский политехнический институт)»
Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов