Исполнитель Робот icon

Исполнитель Робот



НазваниеИсполнитель Робот
Дата конвертации29.07.2012
Размер51.62 Kb.
ТипИнструкция

Исполнитель Робот


Рассмотрим описание исполнителя.


Среда исполнителя: Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки.

СКИ Робота: простые команды: вверх, вниз, влево, вправо, закрасить.

Команды логические: (проверки условия)

сверху свободно снизу свободно

слева свободно справа свободно.

Логические связки: И,НЕ, ИЛИ:

Пример:(Не слева свободно) или (не справа свободно)

Команда ветвления: команда цикла:

если условие то нц пока условие

серия команд серия команд

всё кц

В КИМах 2009 года команды Робота отличались от привычных детям, что приводило к путанице:

^ Команда ветвления: команда цикла:

если условие то нц пока условие делать

серия команд серия команд

конец конец

В КИМах демонстрационного варианта 2010 года формат команд изменен на привычный.

Оценивание задания и разбор типичных ошибок


Задание 23 выполнили на экзамене 2009 года очень немногие учащиеся. Объяснить это можно следующим:

-объём экзаменационной работы в сравнение с отведённым временем был большим и учащиеся просто не успели дойти до последнего задания;

- на уроках изучению данного исполнителя отведено слишком мало времени, а в тех школах, где информатику начинают изучать с 9-го класса и вообще времени на это нет.


Инструкция к оцениванию задания предусматривает

  • 2 балла за безукоризненное выполнение задания;

  • 1 балл при 2-х легкоустранимых ошибках,

  • в остальных случаях -0 баллов.

Хотя возникают неоднозначные моменты, когда можно сомневаться, сколько баллов давать. Например,

При проверке заданий мы сталкиваемся со следующими типичными ошибками:


1.Неверно записан цикл или не указана команда конца цикла. Иногда эта ошибка происходит не из-за незнания, а из-за того, что дети привыкли работать в приложении, где конструкции вставляются целиком и их не приходится дописывать вручную. Как оценивать – как грубую ошибку, тогда за задание ученик получит 0 или как за легкоустранимую?

Многие ошибки происходят из-за невнимательности, если бы дети могли сидеть за компьютерной программой КУМИР, то ошибок по невнимательности можно было бы избежать. Ведь при проверке этого задания для нас важно выяснить логические способности учащегося.


2.
Цикл не применялся, либо условие в цикле записано неверно. Пример:

нц пока справа не свободно вместо нц пока не справа свободно.


3.Неверно закрашены клетки (одна лишняя или одна недокрашена), что происходит из-за того, что команды движения и закрашивания записаны в обратном порядке.


4.Некоторые учащиеся, видимо не понимая смысла структуры «цикл пока», просто подсчитали клетки, которые нужно пройти и закрасить Роботу. Тут, конечно, оценка -0 баллов.


5.Встречаются просто смешные ошибки, когда с ошибками пишут команды «вправо» и «влево» (справа справо направо налево и т.п.)


Разбор задач КИМов с использованием исполнителя Робот.




использовать Робот

алг ким 2009

нач

если не снизу свободно

то вправо

все

если не снизу свободно

то вправо

все

если не снизу свободно

то вправо

все

кон


использовать Робот

алг ким 2010

нач

если не снизу свободно

то вправо

все

если не снизу свободно

то вправо

все

если не снизу свободно

то вправо

все

кон

Разбор некоторых задач с использованием исполнителя Робот.


1.Составьте алгоритм, закрашивающий все внутренние клетки, прилегающие к стене.

использовать Робот

алг

нач

нц пока справа свободно

закрасить; вправо

кц

нц пока снизу свободно

закрасить; вниз

кц

нц пока не снизу свободно

закрасить; влево

кц

кон

2.Составить алгоритм, закрашивающий все клетки между Роботом и стеной. Расстояние до стены неизвестно.

использовать Робот

алг

нач

нц пока справа свободно

вправо; закрасить

кц

кон


3.Составить алгоритм, закрашивающий все клетки, находящиеся между двумя стенами.

использовать Робот

алг уч3

нач

нц пока (не сверху свободно) или (не снизу свободно)

вправо

если (не сверху свободно) и (не снизу свободно)

то

закрасить

все

кц

кон

4.Составить алгоритм, закрашивающий все клетки вокруг прямоугольной стены.


алг уч4

нач

закрасить;вверх

нц пока не справа свободно

закрасить;вверх;

кц

закрасить;вправо

нц пока не снизу свободно

закрасить;вправо;

кц

закрасить;вниз

нц пока не слева свободно

закрасить;вниз;

кц

закрасить;влево

нц пока не сверху свободно

закрасить; влево;

кц

кон


использовать Робот

алг уч5

нач

вправо

нц пока не снизу свободно

закрасить; вправо

кц

закрасить; вниз

нц пока слева свободно

закрасить; влево

кц

нц пока не слева свободно

закрасить; вниз

кц

закрасить;влево;закрасить; вверх;

нц пока сверху свободно

закрасить; вверх

кц

нц пока не сверху свободно

закрасить; влево

кц

кон




Подготовка к выполнению задания 23 на уроках информатики в 9 классе


Для подготовки к выполнению задания 23 мы можем использовать свободно распространяемый пакет КУМИР, автор НИИСИ РАН. В пакет кроме Робота встроен исполнитель Чертёжник, а также Водолей

( Переливашка) и Кузнечик.

Пакет позволяет редактировать, создавая новую обстановку, закрашивать клетки и ставить стены. Очень интересно устроено управление Роботом, которое дублировано- с помощью команд меню или с помощью пульта. К пакету прилагается инструкция, довольно подробная и ясная.

Команды Робота стандартные, единственно, первой строкой алгоритма должна быть: использовать Робот.

Удобно меню Вставка, позволяющее вставить команду или конструкцию.

Меню Инструменты дает возможность создания новых обстановок.

Меню Робот разрешает записать созданную обстановку как стартовую.

Программу можно давать учащимся для установки на домашних ПК, объем в распакованном виде – 17 Мб.




Похожие:

Исполнитель Робот iconИсполнитель Робот
Среда исполнителя: Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки
Исполнитель Робот iconМетодическая разработка по информатике. Тема: «Учебный исполнитель Робот на уроках информатики в 9 классе» Класс: 9 Кол-во занятий: 10
Автор: Вилкова Ольга Юрьевна, учитель информатики высшей категории моу «Лицей №4»
Исполнитель Робот iconПерсональный робот Evolution Robotics er1 для дома и офиса
Личный робот er1, поставляемый в двух конфигурациях, является первым устройством в серии автономных персональных роботизированных...
Исполнитель Робот iconИп шамаева Дарья Геннадьевна огрн 310774611800468, именуемая в дальнейшем «Исполнитель»
«Исполнитель», с одной стороны, и, именуемый (ая) в дальнейшем «Заказчик», с другой стороны, совместно именуемые «Стороны», заключили...
Исполнитель Робот iconДокументы
1. /Гарри Гаррисон -- Безработный робот.doc
Исполнитель Робот iconДокументы
1. /Хейзерман Д. Как самому сделать робот. 1979.djvu
Исполнитель Робот iconMs paint. Задания. Задание №1
Рисунки из одинаковых элементов: 1 – робот из одних прямоугольников, 2 – лошарик (существо из одних окружностей)
Исполнитель Робот iconДоговор № г. Днепропетровск 200 г. Частный предприниматель Сакаев А. З., именуемый в дальнейшем «Исполнитель», с одной стороны, и гр именуемый в дальнейшем "заказчик", с другой стороны, заключили настоящий Договор о следующем: предмет договора
Частный предприниматель Сакаев А. З., именуемый в дальнейшем «Исполнитель», с одной стороны, и гр
Исполнитель Робот iconИсполнитель Альбом

Исполнитель Робот iconИсполнитель: Ran

Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов