Лабораторная работа №2 icon

Лабораторная работа №2



НазваниеЛабораторная работа №2
Группа: Фин-Д-3-3
Дата конвертации27.08.2012
Размер204.25 Kb.
ТипЛабораторная работа

Российский государственный социальный университет

Лабораторная работа №2


Дисциплина: Экономическая кибернетика

Вариант 1

Проверил: Новиков В. Ф.


Выполнила:

Группа: Фин-Д-3-3

Москва


2005 год

Задача 2

Три сталелитейных завода 1, 2 и 3 производят еженедельно, соответственно, 950, 300 и 1350 т стали определенного сорта. Стальные болванки должны быть переданы потребителям А, В, С и Е, еженедельные запросы которых составляют соответственно, 250, 1000, 700 и 650 т стали.

Стоимость транспортировки от завода 1 к каждому потребителю равна, соответственно, 12, 16, 21 и 19 у.е. Стоимость транспортировки от завода 2 к каждому потребителю равна, соответственно, 4. 4, 9 и 5.у.е Стоимость транспортировки от завода 3 к каждому потребителю равна, соответственно, 3, 8, 14 и 10.

Какой нужно составить план распределения стальных болванок, чтобы минимизировать общую стоимость перевозок?


^ ПОРЯДОК ВЫПОЛНЕНИЯ РАБОТЫ:

Данная задача ЛП является транспортной. Для того чтобы решить задачу ЛП в табличном редакторе Microsoft Excel, необходимо выполнить следующие действия.

1. Ввести условие задачи:

a) создать экранную форму для ввода условия задачи:

  • переменных,

  • целевой функции (ЦФ),

  • ограничений,

  • граничных условий;

b) ввести исходные данные в экранную форму:

  • коэффициенты ЦФ,

  • коэффициенты при переменных в ограничениях,

  • правые части ограничений;

c) ввести зависимости из математической модели в экранную форму:

  • формулу для расчета ЦФ,

  • формулы для расчета значений левых частей ограничений;

d) задать ЦФ (в окне "Поиск решения"):

  • целевую ячейку,

  • направление оптимизации ЦФ;

e) ввести ограничения и граничные условия (в окне "Поиск решения"):

  • ячейки со значениями переменных,

  • граничные условия для допустимых значений переменных,

  • соотношения между правыми и левыми частями ограничений.

2. Решить задачу:

a) установить параметры решения задачи (в окне "Поиск решения");

b) запустить задачу на решение (в окне "Поиск решения");

c) выбрать формат вывода решения (в окне "Результаты поиска решения").


^

Исходные данные транспортной задачи

Таблица 1


Стоимость транспортировки, у.е.

А

В

С

Е

Запасы, т

1й завод

12

16

21

19

950

2й завод

4

4

9

5

300

3й завод

3

8

14

10

1350

Потребности у.е

250

1000

700

650






Целевая функция данной задачи имеет вид:

L(X)=12x11+16x12+21x13+19x14+4x21+4x22+9x23+5x24+3x31+8x32+14x33+10x34  min


Ограничения данной задачи имеют вид:

x11+x12+x13+x14=950

x21+x22+x23+x24=300

x31+x32+x33+x34=1350

x11+x21+x31=250

x12+x22+x32=1000 рис.1

x13+x23+x33=700

x14+x24+x34=650

 xij0,  xij – целые числа ( i=1,3; j=1,4)


Экранные формы, задание переменных, целевой функции, ограничений и граничных условий двухиндексной задачи и ее решение представлены на рис. 2, 3 и в табл. 2.


Рис. 2. Экранная форма двухиндексной задачи

(курсор в целевой ячейке G13)

G13==СУММПРОИЗВ(C3:F5;C11:F13)





A

B

C

D

E

F

G

H

I

1




ПЕРЕМЕННЫЕ













ОГРАНИЧЕНИЯ







2




целые

xi1

xi2

xi3

xi4

Лев. Часть

знак

Прав. часть

3




x1j

 

 

 

 

0

=

950

4




x2j

 

 

 

 

0

=

300

5




x3j

 

 

 

 

0

=

1350

6

ОГРАНИЧЕНИЯ

Лев. Часть

0

0

0

0










7

знак

=

=

=

=







2600

8

Прав. Часть

250

1000

700

650




2600

БАЛАНС

9




























10




^ Стоимость транспортировки

xi1

xi2

xi3

xi4










11




x1j

12

16

21

19

ЦФ







12




x2j

4

4

9

5

значение

направление

13




x3j

3

8

14

10

0

min






^

Формулы экранной формы задачи


Таблица 2


Объект математической модели

Выражение в Excel

Переменные задачи

C3:F5

Формула в целевой ячейке G13

=СУММПРОИЗВ(C3:F5;C11:F13)

Ограничения по строкам

в ячейках G3, G4, G5

=СУММ(C3:F3)

=СУММ(C4:F4)

=СУММ(C5:F5)

Ограничения по столбцам

в ячейках С6, D6, E6, F6

=СУММ(C3:C5)

=СУММ(D3:D5)

=СУММ(E3:E5)

= СУММ(F3:F5)

Суммарные запасы и потребности

в ячейках I7, H8

=СУММ(I3:I5)

=СУММ(C8:F8)


Дальнейшие действия производятся в окне "Поиск решения", которое вызывается из меню "Сервис" :

• поставим курсор в поле "Установить целевую ячейку";

• вводим адрес целевой ячейки $G$13

• вводим направление оптимизации ЦФ, щелкнув один раз левой клавишей мыши по селекторной кнопке "максимальному значению"

Задание ячеек переменных

В окно "Поиск решения" в поле "Изменяя ячейки" впишем адреса $C$3:$F$5.
^
Задание граничных условий для допустимых значений переменных

В нашем случае на значения переменных накладывается граничное условие неотрицательности, то есть их нижняя граница должна быть равна нулю: $C$3:$F$5>=0

• Нажмем кнопку "Добавить", после чего появится окно "Добавление ограничения"

• В поле "Ссылка на ячейку" вводим адреса ячеек переменных $С$3:$F$5.

• В поле знака откроем список предлагаемых знаков и выбери ≥.

• В поле "Ограничение" вводим 0.

Аналогично устанавливаем следующие ограничения:

$C$3:$F$5=целое

$C$6:$F$6=$C$8:$F$8

$G$3:$G$5=$I$3:$I$5

Запуск задачи на решение производится путем нажатия кнопки "Выполнить".

После запуска на решение задачи ЛП на экране появляется окно "Результаты поиска решения"




Нажимаем Кнопку «ОК» и получаем результаты решения нашей задачи:


Рис. 3. Экранная форма после получения решения задачи

(курсор в целевой ячейке G13)

G13=СУММПРОИЗВ(C3:F5;C11:F13)





A

B

C

D

E

F

G

H

I

1




ПЕРЕМЕННЫЕ













ОГРАНИЧЕНИЯ







2




целые

xi1

xi2

xi3

xi4

Лев. Часть

знак

Прав. часть

3




x1j

 0

 250

 700

 0

950

=

950

4




x2j

 0

 0

 0

 300

300

=

300

5




x3j

 250

 750

 0

 350

1350

=

1350

6

ОГРАНИЧЕНИЯ

Лев. Часть

250

1000

700

650










7

знак

=

=

=

=







2600

8

Прав. Часть

250

1000

700

650




2600

БАЛАНС

9




























10




^ Стоимость транспортировки

xi1

xi2

xi3

xi4










11




x1j

12

16

21

19

ЦФ







12




x2j

4

4

9

5

значение

направление

13




x3j

3

8

14

10

30450

min





Задача 1

Торговое предприятие для продажи товаров вида А, Б, В использует следующие ресурсы: площадь торговых залов (кв. метры), время младшего торгового персонала (В человеко-часах) и время старшего торгового персонала (в человеко-часах). Объем ресурсов торгового предприятия составляет 90 м2, 370 ч\ч младшего персонала и 120 ч\ч старшего персонала.

Затраты на продажу одной партии товаров вида А составляют 0,1 м2, 0,5 ч\ч младшего персонала и 0,7 ч\ч старшего персонала; затраты на продажу одной партии товаров вида Б составляют 0,3 м2, 0,7 ч\ч младшего персонала и 0,5 ч\ч старшего персонала; затраты на продажу одной партии товаров вида В составляют 0,2 м2, 0,6 ч\ч младшего персонала и 0,6 ч\ч старшего персонала.

Прибыль, полученная от реализации одной партии товаров вида А составляет 5000 у.е.; прибыль, полученная от реализации одной партии товаров вида Б составляет 8000 у.е.; прибыль, полученная от реализации одной партии товаров вида В составляет 6000 у.е.

Сколько партий каждого вида надо заказать торговому предприятию, чтобы прибыль от реализации всех товаров была максимальной?


Решение задачи:


Для упрощения решения задачи, сосредоточим условия задачи в таблице норм расходов ресурсов, проведя условия задачи к однородному виду.

Таблица 1




Ресурс

Расход ресурса на одну партию товара

Объем ресурсов




А

Б

В




Площадь торговых залов, кв.м.

0,1

0,3

0,2

90

Время младшего торгового персонала, ч\ч

0,5

0,7

0,6

370

Время старшего торгового персонала, ч\ч

0,7

0,5

0,6

120
















Прибыль от реализации одной партии товаров, у.е.

5000

8000

6000





Введем переменные:

х1 – количество партий товара А;

х2 – количество партий товара Б;

х3 – количество партий товара В.

^
Составим математическую модель

Целевая функция: Z=5000х1+8000х2+6000х3 → max

Ограничения:

0,1х1+0,3х2+0,2 х3 <= 90

0,5x1+0,7x2+0,6x3 <= 370

0,7x1+0,5x2+0,6x3 <=120

x1 >= 0

x2 >= 0

x3 >= 0
^
Компьютерная реализация с помощью Microsoft Excel


Создадим аналог таблицы 1 в Microsoft Excel. Переменные разместим в разных столбцах. Суммарные расходы и прибыль запишем с помощью функции СУММПРОИЗВ.

Таблица 2







A

B

C

D

E

F

G

H

1







^ Выпуск товаров










2







А

Б

В










3







х1

х2

х3










4

Количество партий

х

0

0

0










5

























6
















Расход

Объем ресурсов

7

Затраты на продажу одной партии товаров

а1j

0,1

0,3

0,2

0

<=

90

8

a2j

0,5

0,7

0,6

0

<=

370

9

а3j

0,7

0,5

0,6

0

<=

120

10

























11

Прибыль, от реализации одной партии товаров

С

5000

8000

6000

0

max





В ячейки столбца F записаны следующие формулы:


^ F7 – СУММПРОИЗВ(C7:D7:E7;C$4:E$4)

F8 – СУММПРОИЗВ(C8:D8:E8;C$4:E$4)

F9 – СУММПРОИЗВ(C9:D9:E9;C$4:E$4)

F11 - СУММПРОИЗВ(C11:D11:E11;C$4:E$4)


В остальные ячейки занесена текстовая и цифровая информация. Для решения задачи перейдем через пункт меню «Сервис» к надстройке «Поиск решения» и заполним форму:


  • Установим целевую ячейку ;

  • Зафиксируем кнопку «максимальному значению»;

  • Зафиксируем ограничения:


C$4 >= 0

D$4 >= 0

E$4 >= 0

F$7 <= H$7

F$8 <= H$8

F$9 <= H$9


Задача решается после нажатия клавиши «Выполнить». Найденные решения записаны в ячейки C4:E4 и исходный лист принял вид:



Таблица 3







A

B

C

D

E

F

G

H

1







^ Выпуск товаров










2







А

Б

В










3







х1

х2

х3










4

Количество партий

х

0

240

0










5

























6
















Расход

Объем ресурсов

7

Затраты на продажу одной партии товаров

а1j

0,1

0,3

0,2

72

<=

90

8

a2j

0,5

0,7

0,6

168

<=

370

9

а3j

0,7

0,5

0,6

120

<=

120

10

























11

Прибыль, от реализации одной партии товаров

С

5000

8000

6000

1920000

max







Похожие:

Лабораторная работа №2 iconДокументы
1. /OOP/Лабораторная работа ь00-Введение.doc
2. /OOP/Лабораторная...

Лабораторная работа №2 iconЛабораторная работа: создание мини-презентации «Памятники Кремля»
Лабораторная работа проводится в компьютерном классе, с подключением к сети Internet
Лабораторная работа №2 iconДокументы
1. /Lab1/Лабораторная работа 1.doc
2. /Lab2/Лабораторная...

Лабораторная работа №2 iconИ я забуду Покажи мне и я запомню, Дай мне действовать самому и я научусь. Китайская мудрость Тема: Лабораторная работа
Тема: «Лабораторная работа «Измерение работы и мощности тока в электрической лампочке»
Лабораторная работа №2 iconДокументы
1. /Nash/lab1/Лабораторная работа ь1.doc
2. /Nash/lab10/Лабораторная...

Лабораторная работа №2 iconЛабораторная работа №2 «Система безопасности Windows xp»
Лабораторная работа №2 «Система безопасности Windows xp» Цель работы: Изучить систему безопасности Windows xp
Лабораторная работа №2 iconЛабораторная работа «Работа в Windows c помощью основного меню. Использование технологии ole»
Запишите размер папки, выраженный в Мб (мегабайтах) в текстовый редактор блокнот
Лабораторная работа №2 iconЛабораторная работа «Работа с текстовыми фрагментами без помощи мыши»
Скопируйте последнее слово получившегося текста и вставьте его в начало текста один раз
Лабораторная работа №2 iconДокументы
1. /Базовые задачи на обработку массива.doc
2. /ЗадачиНаЛиниВетвление.doc
Лабораторная работа №2 iconДокументы
1. /laba/Лабораторная работа ь1.doc
2. /laba/Лабораторная...

Лабораторная работа №2 iconДокументы
1. /механизация/~$б работа ь4.doc
2. /механизация/~$бораторная...

Разместите кнопку на своём сайте:
Документы


База данных защищена авторским правом ©podelise.ru 2000-2014
При копировании материала обязательно указание активной ссылки открытой для индексации.
обратиться к администрации
Документы

Разработка сайта — Веб студия Адаманов